Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 103935

Summary: ssh 3.6.1p2-1 introduces a 2-3 second delay when logging in
Product: [Retired] Red Hat Linux Beta Reporter: Simon Garner <sgarner>
Component: opensshAssignee: Nalin Dahyabhai <nalin>
Status: CLOSED DUPLICATE QA Contact: Brian Brock <bbrock>
Severity: medium Docs Contact:
Priority: medium    
Version: AS-beta1   
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Linux   
URL: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=192207
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2006-02-21 18:58:29 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On:    
Bug Blocks: 100643    

Description Simon Garner 2003-09-08 00:38:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Logging in with ssh gives an erroneous "authentication failure" message in the 
logs and generates a 2-3 second delay before successful login.

This does not occur with previous versions of openssh. Apparently this is due 
to the recent ssh security fix which passes all auth attempts to PAM so that 
the delay on failure is always the same. But in this case no failure should be 
occuring.

Refer to the following debian bug report (which is fixed and closed) for more 
details and solution:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=192207

This is also discussed on the taroon beta list:
https://www.redhat.com/archives/taroon-beta-list/2003-August/msg00171.html

This problem still occurs with the latest Red Hat openssh 3.2.6p2-6.

regards,

-Simon

Version-Release number of selected component (if applicable):
3.6.1p2-2

How reproducible:
Always

Steps to Reproduce:
1. Log in with ssh (using password authentication)
    

Actual Results:
1. authentication failure error in /var/log/messages
2. 2-3 seconds delay
3. successful login

Expected Results:
1. successful login

Additional info:

Comment 1 Michael Young 2003-09-08 12:29:21 UTC
This sounds like the same issue as bug 101157

Comment 2 Jeremy Katz 2003-10-21 20:38:14 UTC

*** This bug has been marked as a duplicate of 101157 ***

Comment 3 Red Hat Bugzilla 2006-02-21 18:58:29 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.