Bug 103937 - Unable to install package after use of up2date
Unable to install package after use of up2date
Status: CLOSED DUPLICATE of bug 83485
Product: Red Hat Linux Beta
Classification: Retired
Component: redhat-config-packages (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-07 20:55 EDT by Santiago Erquicia
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Santiago Erquicia 2003-09-07 20:55:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.9.3

Description of problem:
The program to install packages doesn't use the up2date information and that
makes that some packages that depend on others with specific versions cannot be
installed after update.

I installed libxmlt, after that, up2date did an update.  Now I want to install
the devel package libxmlt-devel.  As the only one availabe to
redhat-config-packages is the original one, and this requires an specific
version of libxmlt, already updated, the requisites of the package are not met.

So, now there is no way I can install this devel package.

I assume that all the devel packages depend on the exact same version as the non
devel package.  So, if you do not install all the devel packages when you
install some packages, and up2date updates it, you no longer can install them
(at least with this tools)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
They are explained above
    

Additional info:

up2date should keep at least all the new packages somewhere where
redhat-config-packages can search so when they are required they can be downloaded.
Comment 1 Michael Young 2003-09-08 09:55:26 EDT
up2date libxmlt-devel
should do what you want.
Comment 2 Santiago Erquicia 2003-09-08 10:23:57 EDT
I didn't know that.  Thanks, but anyway, it is not clear.

If up2date already can do it, why gnome-config-package doesn't call up2date por
the packages that didn't find on the CDs?
Comment 3 Jeremy Katz 2003-09-08 15:53:42 EDT

*** This bug has been marked as a duplicate of 83485 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:58:30 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.