Bug 83485 - updated components can prevent installation of additional packages from CD
updated components can prevent installation of additional packages from CD
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 84238 87855 89139 89633 103937 105971 (view as bug list)
Depends On:
Blocks: 120517
  Show dependency treegraph
 
Reported: 2003-02-04 15:42 EST by Gord Thompson
Modified: 2007-04-18 12:50 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-21 16:19:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gord Thompson 2003-02-04 15:42:53 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
Installed 8.0 from CD as a typical workstation. Over the past few months I have
applied various patches and updates when prompted by the Notification Tool.

Then went to install a Perl module from CPAN, and the 'make' failed because gcc
was not installed. So, I ran

redhat-config-packages

to install the 'Development Tools' from the CD, but it wouldn't let me because
it was unable to locate two items:

cyrus-sasl-2.1.7-2
krb5-libs-1.2.5-6

However, there were newer versions of those two items in place, namely

cyrus-sasl-2.1.10-1
krb5-libs-1.2.5-8

So I had to use rpm to --force install the older versions, then install the
'Development Tools', then update the two items again.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. Fresh install without Development Tools
2. Apply all patches via up2date
3. Try to install Development Tools from CD
    

Additional info:

Also found this in groups.google.com, so I know it's not just me:

Newsgroups: linux.redhat.rpm
Subject: problems with the updated rpms
Date: 23 Jan 2003 09:44:02 -0800
Organization: http://groups.google.com/
Lines: 12
Message-ID: <d2fb770b.0301230944.79fdff15@posting.google.com>
NNTP-Posting-Host: 213.157.171.207
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 8bit
X-Trace: posting.google.com 1043343843 26574 127.0.0.1 (23 Jan 2003 17:44:03 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: 23 Jan 2003 17:44:03 GMT


Hi!

  I have installed Redhat 8.0 and I updated some packages (including
cyrus-sasl and krb5-libs) using the up2date tool.
  The problem is that I want to install the "development tools" part,
using the pachage manager and the presented packages are labeled as
"unlocatable".
  In fact, I have installed newer versions of them.

Can anyone help?
Thanks,
  cristi
Comment 1 Jeff Stern 2003-02-06 21:16:42 EST
i had same prob, except with not only cyrus-sasl and krb5-libs, but also with
open-ldap. it wanted the older one of that, too, even though i had a newer one
already installed.
Comment 2 Jeremy Katz 2003-02-09 16:54:32 EST
This is going to be difficult to impossible to fix without having
redhat-config-packages tie into RHN.  
Comment 3 Gord Thompson 2003-02-10 09:13:12 EST
>This is going to be difficult to impossible to fix without having
>redhat-config-packages tie into RHN.

Well, if that's what it takes.... 

Automatic updates are essential for the security of the machine, the safety of
the user, and the health of the Internet (ref: SQL_Slammer). And we can't expect
the user to know with certainty what they will want installed from the CD during
the initial setup.

What redhat-config-packages needs is a way to determine

1. if the required package is installed, and if so
2. if the version is the same or newer than the required version.

In this case, the following would have made that determination:

<pre>

#!/usr/bin/perl

$required = 'cyrus-sasl-2.1.7-2';
$installed = 'cyrus-sasl-2.1.10-1';

($pkg_req, $maj_req, $med_req, $min_req, $rev_req) = pkg_parse($required);
($pkg_ins, $maj_ins, $med_ins, $min_ins, $rev_ins) = pkg_parse($installed);

print "Package: ", $pkg_req, "\n\n";
print "   required:    Major = ", $maj_req, "\n",
      "               Medial = ", $med_req, "\n",
      "                Minor = ", $min_req, "\n",
      "             Revision = ", $rev_req, "\n\n";
print "  installed:    Major = ", $maj_ins, "\n",
      "               Medial = ", $med_ins, "\n",
      "                Minor = ", $min_ins, "\n",
      "             Revision = ", $rev_ins, "\n\n";

if ($maj_ins>$maj_req) {
	$ok = 1;
}
elsif ($maj_ins<$maj_req) {
	$ok = 0;
}
else {
	if ($med_ins>$med_req) {
		$ok = 1;
	}
	elsif ($med_ins<$med_req) {
		$ok = 0;
	}
	else {
		if ($min_ins>$min_req) {
			$ok = 1;
		}
		elsif ($min_ins<$min_req) {
			$ok = 0;
		}
		else {
			$ok = ($rev_ins>=$rev_req);
		}
	}
}

if ($ok) {
	print "The installed version is the same or newer than the required version\n";
}
else {
	print "The installed version is older than the required version\n";
}


sub pkg_parse {
	($_) = @_;
	/(.+)-(\d+)\.(\d+)\.(\d+)-(\d+)$/;
	my @parsed = ($1, $2, $3, $4, $5);
	return @parsed;

}

</pre>
Comment 4 Jeremy Katz 2003-02-13 14:33:11 EST
*** Bug 84238 has been marked as a duplicate of this bug. ***
Comment 5 Michael Schwendt 2003-03-25 08:50:26 EST
Thanks for not responding to bug #78638 where all of this has been documented
earlier. :-(
Comment 6 Gord Thompson 2003-03-25 09:17:46 EST
>Thanks for not responding to bug #78638

I did search for related bugs before posting. Had I found that one, I might 
have reopened it....
Comment 7 Jeremy Katz 2003-04-08 20:09:45 EDT
*** Bug 87855 has been marked as a duplicate of this bug. ***
Comment 8 Jeremy Katz 2003-05-05 12:35:26 EDT
*** Bug 89633 has been marked as a duplicate of this bug. ***
Comment 9 Dirk MG Seynhaeve 2003-08-22 17:47:59 EDT
Similar issue in RH9:
Trying to install several packages (KDE, VIM, Xemacs, ...) fails:
unlocatable package:
openssh-3.5p1.6

However:
rpm -qa | grep openssh
openssh-3.5p1.6-9
Comment 10 Chad Brown 2003-08-24 01:25:46 EDT
Similar problem in RH9.

I performed a farily vanilla server install of RH9 plus KDE. Then ran Up2Date 
to get all the latest patches.

However, I decided to add some dev packages. I then recieved a packages not 
found warning. (Krb5-libs = 1.2.7-8 and Openssl = 0.9.7a-2 not found) Due to 
Up2Date I am actually running newer versions.

Any Advice?
Comment 11 Michael Schwendt 2003-08-24 09:20:56 EDT
The work-around is to install the updated development packages with up2date
prior to installing the rest with redhat-config-packages:

  up2date krb5-devel openssl-devel

You may need to do the same for any other package which causes problems in
redhat-config-packages.
Comment 12 Jeremy Katz 2003-09-08 15:53:52 EDT
*** Bug 103937 has been marked as a duplicate of this bug. ***
Comment 13 Jeremy Katz 2003-10-01 16:33:58 EDT
*** Bug 105971 has been marked as a duplicate of this bug. ***
Comment 14 Jeremy Katz 2003-10-06 17:23:04 EDT
*** Bug 89139 has been marked as a duplicate of this bug. ***
Comment 15 Chris Evich 2005-04-20 10:52:02 EDT
It would be _really_ nice if up2date simply understood the package "groups". 
Then up2date could be a better workaround for this.  

Could problem be somehow related to the installed comps.xml not being updated?  

AFAIK, there is no other convenient way to install whole "groups" of packages.
This and the CD mount problem are becoming quite frustrating for people.  I am
receiving ever increasing reports of this problem from many folks.  (Hopefully
this is the best place to report it).
Comment 16 Jeremy Katz 2005-09-21 16:19:30 EDT
This report is filed against a product which is no longer supported.  It is very
likely that the problem is resolved in the current version of Fedora Core or
scheduled to be resolved with the new system-config-packages scheduled to land
in Fedora Core 5.

Note You need to log in before you can comment on or make changes to this bug.