Bug 1039699 - [GSS] (6.2.x) Cannot use deployments with same runtime-name in a domain
Summary: [GSS] (6.2.x) Cannot use deployments with same runtime-name in a domain
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: CR1
: EAP 6.2.1
Assignee: Brian Stansberry
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Depends On: 1040621
Blocks: eap62-cp01-blockers 1040681
TreeView+ depends on / blocked
 
Reported: 2013-12-09 20:16 UTC by dereed
Modified: 2018-12-04 16:35 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The code used to parse a domain.xml file was incorrectly validating that all runtime-name configuration values were unique across all deployments in the domain. This was incorrect, as these values only need to be unique within a set of deployments mapped to a server group. Using two deployments with the same runtime-name in the domain (for example, two different versions of the same deployment) would result in a fatal boot error if the domain controller was restarted, with output like this in the host controller log: JBAS010932: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration ... Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1348,9] ... Message: JBAS014664: An element of this type named 'foo' has already been declared The scope of XML parser validation of runtime-name uniqueness has been limited to an individual server group. Post-parsing validation of the management configuration model has also been improved to exclude deployments marked as not enabled. Restarting a domain controller whose config includes two deployments with the same runtime-name now works.
Clone Of:
: 1040621 (view as bug list)
Environment:
Last Closed: 2014-02-24 20:14:16 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2633 Major Resolved Cannot use deployments with same runtime-name in a domain 2017-11-20 09:37:12 UTC

Description dereed 2013-12-09 20:16:13 UTC
Description of problem:

Regression introduced with https://bugzilla.redhat.com/show_bug.cgi?id=983980

The check for duplicate runtime-name in a server group on startup is too aggressive.  It is incorrectly throwing an error on startup if there are any duplicate runtime-names in the whole domain, instead of just in a single server group.


Version-Release number of selected component (if applicable):

EAP 6.2


How reproducible:

Always


Steps to Reproduce:

1.  Start a single HC/DC
2.  deploy --name=foo1 --runtime-name=bar --disabled testfile
3.  deploy --name=foo2 --runtime-name=bar --disabled testfile
4.  restart the DC/HC

Actual results:

JBAS010932: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
...
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1348,9]
...
Message: JBAS014664: An element of this type named 'foo' has already been declared


Expected results:

No errors

Comment 1 dereed 2013-12-09 20:21:59 UTC
Copy/paste error in the error message in the previous comment (that error was from a test with a different runtime-name).
The actual error message is "An element of this type named 'bar' has already been declared" for the listed test case.

Comment 4 Brian Stansberry 2013-12-11 00:27:21 UTC
The BZ 983980 fix also introduces a regression in the behavior of standalone servers. The check for a unique runtime name should only involve deployments that are enabled.

Comment 7 Scott Mumford 2014-01-20 00:21:21 UTC
Marking for inclusion in the 6.2.1 Release Notes documentation.

Comment 8 Nikoleta Hlavickova 2014-01-24 08:49:11 UTC
Verified with 6.2.1.CP.CR1-patch.


Note You need to log in before you can comment on or make changes to this bug.