Bug 1040621 - [GSS] (6.3) Cannot use deployments with same runtime-name in a domain
Summary: [GSS] (6.3) Cannot use deployments with same runtime-name in a domain
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Domain Management
Version: 6.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: DR0
: EAP 6.3.0
Assignee: Brian Stansberry
QA Contact: Petr Kremensky
Russell Dickenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 1039699
TreeView+ depends on / blocked
 
Reported: 2013-12-11 17:34 UTC by Brian Stansberry
Modified: 2018-12-04 16:37 UTC (History)
7 users (show)

(edit)
In previous versions of JBoss EAP 6, the check for duplicate values for deployment runtime-name attributes in a server group on startup was too aggressive.  It was incorrectly throwing an error on startup if there were any duplicate runtime-names in the whole domain, instead of just in a single server group.

As a result, including multiple deployments in a domain with the same runtime-name would result in a boot failure even if those deployments are not mapped to the same server group.

For example:
----
JBAS010932: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
...
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[1348,9]
...
Message: JBAS014664: An element of this type named 'example.war' has already been declared
----
 
In this release the validation of uniqueness of runtime names was moved from the XML parser to the operation execution logic, and the validation logic was adjusted to ignore duplicates not associated with the same server group.

Multiple deployments with the same runtime-name value can now coexist in a domain so long as they are not mapped to the same server group.
Clone Of: 1039699
(edit)
Last Closed: 2014-06-28 15:26:24 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-2633 Major Resolved Cannot use deployments with same runtime-name in a domain 2016-03-11 01:46 UTC

Comment 2 Petr Kremensky 2014-02-24 14:28:20 UTC
Verified on EAP 6.3.0.DR0.


Note You need to log in before you can comment on or make changes to this bug.