Bug 104061 - php-4.3.2-7 doesn't compile again current
Summary: php-4.3.2-7 doesn't compile again current
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: php   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joe Orton
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-09 15:31 UTC by Pasi Pirhonen
Modified: 2007-11-30 22:06 UTC (History)
0 users

Fixed In Version: 4.3.2.9.ent
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-11 14:07:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Pasi Pirhonen 2003-09-09 15:31:27 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030830
Debian/1.4-3.he-1

Description of problem:
Fails test which seems to related to glibc-2.3.2-77 (iconv)

=====================================================================
TIME END 2003-09-09 03:44:06
=====================================================================
TEST RESULT SUMMARY
---------------------------------------------------------------------
Exts skipped    :   54
Exts tested     :   33
---------------------------------------------------------------------
Number of tests :  476
Tests skipped   :  113 (23.7%)
Tests warned    :    0 ( 0.0%)
Tests failed    :    1 ( 0.2%)
Tests passed    :  362 (76.1%)
---------------------------------------------------------------------
Time taken      :  226 seconds
=====================================================================

=====================================================================
FAILED TEST SUMMARY
---------------------------------------------------------------------
Bug #16069 [ext/iconv/tests/bug16069.phpt]
=====================================================================
make: *** [test] Error 1
++ find .. -name '*.diff' -type f -print
+ cat ../ext/iconv/tests/bug16069.diff


Version-Release number of selected component (if applicable):
php-4.3.2-7

How reproducible:
Always

Steps to Reproduce:
1. Try to recompile again current
    

Actual Results:  Fails to recompile

Additional info:

System is up to current from up2date.

Comment 1 Joe Orton 2003-09-09 15:38:31 UTC
php-4.3.2-8.ent turned that test off, though it would be interesting to know
whether this really is a bug in the glibc iconv.

Comment 2 Pasi Pirhonen 2003-09-09 15:55:20 UTC
Gimme few hours. I'll install a clean beta2 and start the iteration from there.


Comment 3 Pasi Pirhonen 2003-09-09 18:41:57 UTC
Duh! Mystical enought the buiding works aOK if i use command like

LC_ALL=fi_FI@euro rpmbuild -ba php.spec

I really don't know enought about php and glibc to make any assumtions.
The system was stil 'up to date EL3-beta'.


Comment 4 Joe Orton 2003-09-09 19:12:57 UTC
Ah, good catch.  What is your $LANG setting normally?  I also had to unset TZ to
fix some build failures, must be some env vars are getting leaked which weren't
previously or something.

Comment 5 Pasi Pirhonen 2003-09-09 19:25:38 UTC
My env for these 'test-setups' are just pretty much defaultwhich would be

LANG=en_US.UTF-8
LANGVAR=en_US.UTF-8

(those seems to be only related ones)

The spec-file at least claims to be setting 'LANG=C' as usually

Actually 'LC_ALL=fi_FI' builds just fine too, but for example
'LC_ALL=fi_FI.UTF-8' does not. So it seems to be UTF-8 related.


Comment 6 Pasi Pirhonen 2003-10-19 00:16:13 UTC
Shouldn't this be closed already?


Comment 7 Joe Orton 2003-11-11 14:08:39 UTC
Yes, this was fixed for the final release.  Thanks for the report.


Note You need to log in before you can comment on or make changes to this bug.