Bug 16069 - Pump exits if it can't renew the lease
Pump exits if it can't renew the lease
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Elliot Lee
:
: 16928 18174 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-12 12:20 EDT by John William
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 09:42:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John William 2000-08-12 12:20:28 EDT
I'm running standard RH6.2, with pump-0.7.8-1. The machine has two 
ethernet cards, eth0 on the local network and eth1 connected to the 
Internet. eth0 is a static IP and eth1 is DHCP from my service provider.

The machine has a 14 day uptime when the eth1 link was broken for several 
hours. During this time, the eth1 lease expired but when pump tried to 
renew it I got:

Aug 12 10:10:16 dns1 pumpd[362]: failed to renew lease for device eth1
Aug 12 10:10:17 dns1 pumpd[362]: terminating as there are no more devices 
under management

in /var/log/messages. So when the link was restored, I had to manually 
restart pump since it had exited. Pump has been associated with the eth1 
interface via Linuxconf 1.19r2 by selecting "dhcp" for config mode on eth1.
Comment 1 Olivier Baudron 2000-08-13 02:36:31 EDT
You may have a look at bug 10348 for more information (probably the same bug).
Comment 2 John William 2000-10-24 19:46:43 EDT
I just got bitten by this bug (again) with pump-0.8.3-2, included with RedHat 
7. In bug 10348, it was mentioned that the patch was applied. I haven't 
verified the source to see if that is true, but pump (after successfully 
obtaining a lease) will exit if any subsequent renewal fails (when it 
shouldn't).
Comment 3 Olivier Baudron 2000-11-25 15:08:48 EST
Yes, pump-0.8.3-2 has been patched. However, as I mentioned more than 6 months
ago in bug 10354, once bug 10348 is fixed, there is another bug that makes pump
dies, if the network is broken while renewing the lease.
These two reports were closed at the same time by Redhat when they fixed bug
10348. So they probably made a confusion.

I have just reopened bug 10354.
Comment 4 Elliot Lee 2001-07-19 15:09:06 EDT
Closed in conjunction with 10354
Comment 5 Elliot Lee 2001-07-19 18:07:46 EDT
*** Bug 16928 has been marked as a duplicate of this bug. ***
Comment 6 Elliot Lee 2001-07-20 00:37:25 EDT
*** Bug 18174 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.