Bug 104107 - diffutils is missing wdiff (word-by-word diffs)
Summary: diffutils is missing wdiff (word-by-word diffs)
Status: CLOSED DUPLICATE of bug 68537
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: diffutils (Show other bugs)
(Show other bugs)
Version: 9
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-09 21:48 UTC by Neal McBurnett
Modified: 2007-04-18 16:57 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 14:19:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Neal McBurnett 2003-09-09 21:48:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3b) Gecko/20030210

Description of problem:
The world needs better support for doing word-by-word differences between files.

The program already exists: wdiff from gnu.org.

Debian includes it already:
  http://packages.debian.org/stable/text/wdiff.html

In fact the a2ps package which is already in redhat since
at least 7.3 relies on wdiff by default.  See bug 68537.


Version-Release number of selected component (if applicable):
diffutils-2.8.1-6

How reproducible:
Always

Steps to Reproduce:
pdiff a b


Actual Results:  /usr/bin/pdiff: line 179: wdiff: command not found
[stdin (wdiff): 0 pages on 0 sheets]
[Total: 0 pages on 0 sheets] saved into the file `q.ps'


Expected Results:  [stdin (wdiff): 1 page on 1 sheet]
[Total: 1 page on 1 sheet] saved into the file `q.ps'


Additional info:

thanks for helping with this!

Comment 1 Neal McBurnett 2003-09-09 21:54:11 UTC
Another data point: mandrake has a separate package for wdiff:

http://rpmfind.net//linux/RPM/cooker/contrib/i586/wdiff-0.5-5mdk.i586.html

Comment 2 Tim Waugh 2004-12-10 14:19:23 UTC

*** This bug has been marked as a duplicate of 68537 ***


Note You need to log in before you can comment on or make changes to this bug.