Bug 68537 - missing dependency: wdiff
missing dependency: wdiff
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: a2ps (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Bill Nottingham
:
: 104107 (view as bug list)
Depends On:
Blocks: FC4Target
  Show dependency treegraph
 
Reported: 2002-07-10 20:31 EDT by Ulrich Drepper
Modified: 2014-03-16 22:28 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.13b-46
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-23 11:15:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2002-07-10 20:31:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a+) Gecko/20020628

Description of problem:
pdiff, part of a2ps, uses wdiff when not used with the -l option.  The wdiff is
no dependency for a2ps, though.  This leads to errors for all uses of pdiff
except when -l is used.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.pdiff /dev/null /dev/null -- -Pdisplay
2.
3.
	

Actual Results:  /usr/bin/pdiff: wdiff: command not found


Expected Results:  If wdiff would be available the correct output would be used.

Additional info:

If wdiff cannot be provided (and I know it has some problems) the -l should be
made the default and maybe the -w option should be disabled.
Comment 1 Neal McBurnett 2003-09-09 17:35:22 EDT
This bug is still a problem in redhat 9 - please change the version number.

debian has a package for wdiff:

 http://packages.debian.org/stable/text/wdiff.html

which patches the tar.gz from gnu.org to keep it from
dumping core at least.

Wouldn't it make sense to add the patched wdiff to diffutils?
It is a nice program.
Comment 2 Tim Waugh 2004-12-10 09:19:35 EST
*** Bug 104107 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2004-12-10 16:51:06 EST
It's ok with me to add it.
Comment 4 Tim Waugh 2004-12-13 10:44:33 EST
Extras or Core though?
Comment 5 Bill Nottingham 2004-12-13 20:28:30 EST
If a2ps is trying to call it, I suppose it should be in Core.

Note You need to log in before you can comment on or make changes to this bug.