Bug 104156 - unable to login after updating gdm
unable to login after updating gdm
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: gdm (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-10 11:45 EDT by Elton Woo
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 06:52:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elton Woo 2003-09-10 11:45:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After updating to this version from rawhide, I am unable to
login either as user or root. The error message says that
either I'm entering the wrong user name, wrong password, or
that I might have my Caps Lock engaged.

I verify that this is NOT the case. My userID is just three
letters, and I have both that and my password _written down
on paper_ (no problem, as I am the only user, an no one
else has physical access).

NOTE: During install, I have always selected Canadian English
as the default language. However, I am NOT using a bilingual
keyboard, but a standard "no-name" US one.

So far, I have been able to verify this *twice*. Hence, most
updates from rawhide have been applied to the system, EXCEPT
gdm-2.4.4.0-2.i386.rpm.



Version-Release number of selected component (if applicable):
gdm-2.4.4.0-2

How reproducible:
Always

Steps to Reproduce:
1. Update to gdm-2.4.4.0-2
2. Logout, and try to login as user or root.
3.
    

Actual Results:  login manager complains that either incorrect user ID or password 
has been entered, or that the Caps Lock key might be on.

Expected Results:  password should be accepted, and login should proceed.

Additional info:

CPU: AMD Athlon
Video driver: NVidia (latest version, Sep. 2003)
Comment 1 Nalin Dahyabhai 2003-09-10 12:10:23 EDT
I can't reproduce this on my devel box (as root, a local test account, or my own
account).  Are any error messages logged to /var/log/messages or /var/log/secure
when this happens?
Comment 2 Elton Woo 2003-09-10 12:44:08 EDT
The last time this happened, I couldn't get into the system, and I hit the reset
button <*DUH*>. Consequently, I did a clean install, so I lost any logs. I'm
willing to retest again, but my default login is graphical. Could you give
me "newbieized" instructions on how, what I should do, _in case this happens
again_ so i can safely get into the system and revert to the previous version of
the gdm?

I was hesitant in posting this as a bug, but there was a comment on the list: 

-----------------------BEGIN QUOTE-------------------------------
Re: *critical* bug in gdm-2.4.4.0-2 from rawhide?

    * From: Elton Woo <elwoo videotron ca>
    * To: rhl-beta-list redhat com
    * Subject: Re: *critical* bug in gdm-2.4.4.0-2 from rawhide?
    * Date: Mon, 08 Sep 2003 16:58:06 -0400

On September 8, 2003 04:16 pm, Jean Francois Martinez Jean Francois Martinez 
<jfm512 free fr> wrote:
> Most likely and unbeknown to you you were using the US keyboard when
> you installed Severn.  It happens to me when I ask for install in
> American and later for a french keyboard.  The keyboard is changed
> for the text console but not for the anaconda GUI then so when I
> type the password at install time I get a "foobQr" when what I typed
> was "foobAr".  Solution is easy: do an install in the canadian
> language.  :-)

-----------------------BEGIN QUOTE-------------------------------

If I knew how to identify the manufacturer of my keyboard, I might be
able to give you some more detail on the hardwar. It is acrylic blue with
white keys, and has the "windows" keys between the CRTRL and ALT, with
three other keys (Sleep, Wake Up, and Power) above the number pad.

The only other thing that comes to mind, is that sometimes (rarely), I lose
my mouse pointer, and have to unplug then replug the mouse from my hub.
IMHO, this shouldn't affect the key entry, as the cursor bar *is* within
the dialog entry space.
Comment 3 Nils Philippsen 2003-09-10 13:53:06 EDT
You can always press Ctrl+Alt+F1 and login through the text console.

To check whether this is some weird key mapping error, type in the password in
the username field, so you can see whether a key is mapped wrongly. Delete
(backspace) the password, otherwise it will show up plaintext in /var/log/secure
when you try to login.
Comment 4 Elton Woo 2003-09-10 23:54:14 EDT
hmmm... I guess by the time I created the bug report the bug was already *fixed*!
<*DUH*>. This version 2.4.4.0-2 works. The only way that I can tell from the
version which caused me problems is that 2.4.4.0-2 presents me with three session
choices: 1. Default, 2. KDE, and 3. Fail Safe. I guess it was the previous version
which caused me grief. *That one* presented me with these session numbers and
choices: 1. Default, 2. KDE, 3. Gnome, and 4. Failsafe.

The updated packages were moved to an "INSTALLED" directory, and though I had
deleted the "problem" gdm, I kept the rest, so it must have been a version 
which I downloaded either on the 3rd or the 4th. (My apologies). I guess you
can consider this bug closed.

Note You need to log in before you can comment on or make changes to this bug.