Bug 104173 - xmms (and other applications) crash with message libgcc_s.so.1 must be installed for pthread_cancel to work
xmms (and other applications) crash with message libgcc_s.so.1 must be instal...
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: glibc (Show other bugs)
beta1
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-10 14:40 EDT by Keith Lea
Modified: 2016-11-24 10:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-11 03:39:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith Lea 2003-09-10 14:40:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030909
Firebird/0.6.1+

Description of problem:
I'm not sure if glibc is the right component for this, but the only other bug
involving pthread_cancel is under glibc.

XMMS crashes (usually only when switching songs) and prints "libgcc_s.so.1 must
be installed for pthread_cancel to work" to the console. Other applications have
done this as well but I don't remember what they were now. XMMS does it after
almost every song.

I am using kernel-2.4.22-1.2039.nptl and I do have libgcc_s.so.1:

lrwxrwxrwx    1 root     root           28 Sep 10 00:23 /lib/libgcc_s.so.1 ->
libgcc_s-3.3.1-20030904.so.1*
-rwxr-xr-x    1 root     root        29196 Sep  8 13:53
/lib/libgcc_s-3.3.1-20030904.so.1*

This happens with XMMS 1.2.7 and 1.2.8.


Version-Release number of selected component (if applicable):
glibc-2.3.2-82

How reproducible:
Always

Steps to Reproduce:
1. Run XMMS
2. Switch songs or let a song finish so the next song is played

Additional info:
Comment 1 Jakub Jelinek 2003-09-10 17:43:08 EDT
Are you sure you don't have a different (older) libgcc_s.so.1 lurking somewhere
in your library search path (if LD_LIBRARY_PATH is used there, if not,
in ld.so.cache)?
pthread_cancel is trying to dlopen libgcc_s.so.1, which has:
_Unwind_Resume
__gcc_personality_v0
_Unwind_ForcedUnwind
_Unwind_GetCFA
symbols exported from it.
E.g. strace output (or LD_DEBUG=all dump) could make it clearer what's going on.
Comment 2 Keith Lea 2003-09-10 20:06:32 EDT
It looks like I did have another libgcc_s.so.1 in /usr/local/lib, and removing
it fixes the crash. Removing /usr/local/lib/libstdc++.* also fixes my GLIBC
errors in other applications. I don't know if I'm supposed to resolve the bug,
so I won't, but I'm all set now. Thanks for the help. (Any idea why this would
happen? This is sort of an old system (I started with RH7.3, so it's not thta
old), but I don't remember ever manually installing glibc or gcc or anything.)
Comment 3 Jakub Jelinek 2003-09-11 03:39:52 EDT
That really looks like manually installed gcc.
Comment 4 Simon 2004-05-03 14:57:28 EDT
Worth looking at this other bug:

http://bugzilla.redhat.com/bugzilla/long_list.cgi?buglist=104689

Similar symptoms that boiled down to a problem with NPTL. Solution:

export LD_ASSUME_KERNEL=2.4.19 

... before running xmms. Works wonders for me, too! :)

Note You need to log in before you can comment on or make changes to this bug.