Bug 104275 - Mozilla doesn't download .rpm files.
Mozilla doesn't download .rpm files.
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: mozilla (Show other bugs)
beta1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Christopher Blizzard
Ben Levenson
:
: 104280 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-11 18:27 EDT by Féliciano Matias
Modified: 2007-03-27 00:09 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-04-03 10:13:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Féliciano Matias 2003-09-11 18:27:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Mozilla doesn't download rpm files via http.

Version-Release number of selected component (if applicable):
mozilla-1.4-12

How reproducible:
Always

Steps to Reproduce:
Just try to download one rpm from http://lisas.de/~nils/redhat/rawhide/RPMS/i386/.
Comment 1 Bill Nottingham 2003-09-12 00:04:33 EDT
Works for me, trying SDL_ttf...
Comment 2 Féliciano Matias 2003-09-12 10:55:25 EDT
*** Bug 104280 has been marked as a duplicate of this bug. ***
Comment 3 Féliciano Matias 2003-09-12 20:55:17 EDT
> Works for me

The problem appeart some days ago.
This system is sync to the current rawhide.
I check my system with "rpm -V -a". Seems OK.
I set /etc/sysconfig/i18n to "en_GB.UTF-8" to avoid locale issue (I usally use
"fr_FR.UTF8").
Create a new account.
Log in into gnome. Launch mozilla and browse http://lisas.de/~nils/redhat/rawhide/ .
Try to download a package but without success.
I can't download anything form any website.
The initial bug report is wrong. I can't download via ftp also :-)
Comment 4 Elton Woo 2003-09-13 14:04:32 EDT
No problem here. I've just downloaded a file from that
sitehttp://lisas.de/~nils/redhat/rawhide/, by clicking
on an rpm package, and selecting "save as:" and pointing
to my download directory. All system updates are from
rawhide, and current as of 12 Sep. However, I have not 
*ever* encountered download difficulties with mozilla.

What error messages pop up when you try a download?
Do you have cookies enabled / disabled?

FYI: my security settings on mozilla are thus:
Privace settings are "high". Lifetime is limited to
"current session", and in Scripts and Plugins "read cookies" is disabled.
Comment 5 Féliciano Matias 2003-09-13 14:22:05 EDT
> What error messages pop up when you try a download?

No error message, no popup, nothing.
Mozilla Default setting.
No problem with epiphany.
Comment 6 Féliciano Matias 2003-09-16 20:47:21 EDT
I found the problem.
Since I use evolution, I have removed mozilla-mail.
But mozilla (the browser) need mozilla-mail to download files.
Comment 7 Ian Laurie 2003-09-29 06:35:23 EDT
I have this problem also with mozilla-1.4-12.

I can not download *anything*.  Right click "save link target as" also fails.
In my case, mozilla-mail is installed.

Install of rh9 was the complete CD.... everything installed.  Don't know if 
that is what my problem is.

Also, after rh9 install, the default mozilla was very broken.  Even Help:About 
produced a blank page.  Also if you clicked on a documentation (redhat manual) 
link from the menu, and there was another manual already open, the second 
browser came up with a blank screen.  Too many problems to mention, and a 
complete CD install produced identical broken results on 3 different systems.  
Don't know if this is a clue/relevant to the current mozilla-1.4-12 problem.


This is how I upgraded to mozilla-1.4-12 from rh9 CD install:

#
# Uninstall Mozilla dependancies.
#
rpm -e galeon
rpm -e kdebindings-devel
rpm -e kdebindings
rpm -e plugger

#
# Uninstall Mozilla.
#
rpm -e mozilla-dom-inspector
rpm -e mozilla-js-debugger
rpm -e mozilla-psm
rpm -e mozilla-mail
rpm -e mozilla-chat
rpm -e mozilla-devel
rpm -e mozilla
rpm -e mozilla-nss-devel
rpm -e mozilla-nss
rpm -e mozilla-nspr-devel
rpm -e mozilla-nspr

#
# Install New Sun Java Engine for Mozilla.
#
rpm -i j2re-1_4_2-linux-i586.rpm

#
# Install Mozilla.
#
rpm -i mozilla-nspr-1.4-12.i386.rpm
rpm -i mozilla-nspr-devel-1.4-12.i386.rpm
rpm -i mozilla-nss-1.4-12.i386.rpm
rpm -i mozilla-nss-devel-1.4-12.i386.rpm
rpm -i mozilla-1.4-12.i386.rpm
rpm -i mozilla-devel-1.4-12.i386.rpm
rpm -i mozilla-chat-1.4-12.i386.rpm
rpm -i mozilla-mail-1.4-12.i386.rpm
rpm -i mozilla-psm-1.4-12.i386.rpm
rpm -i mozilla-js-debugger-1.4-12.i386.rpm
rpm -i mozilla-dom-inspector-1.4-12.i386.rpm

#
# Install other stuff.
#
rpm -i plugger-4.0-23.i386.rpm
rpm -i kdebindings-3.1-6.i386.rpm  
rpm -i kdebindings-devel-3.1-6.i386.rpm  


Then to get Java working:

cd /usr/lib/mozilla-1.4/plugins
ln -s /usr/java/j2re1.4.2/plugin/i386/ns610-gcc32/libjavaplugin_oji.so
Comment 8 Ian Laurie 2003-10-05 01:20:49 EDT
I've found the problem in my case, but I suspect the problem I've found relates 
to a number of bugs reported across bugzilla.

The version of Galeon supplied on the RedHat 9.0 CD set isn’t compatible with 
the supplied version of Mozilla.

Although Galeon works just fine, it breaks the Mozilla installation whenever it 
is run.  The Mozilla file that gets corrupted is:

/usr/lib/mozilla-1.2.1/components/compreg.dat

If you must install and use Galeon make sure you save a copy of the above 
configuration file before you actually run Galeon and reinstate the original 
contents before switching back to Mozilla.

The updated Galeon (not from RedHat) also breaks mozilla-1.4-12 from rawhide.  
The file that gets corrupted is:

/usr/lib/mozilla-1.4/components/compreg.dat

Once broken you can fix mozilla by forcing the file back to its original state 
by:

rpm –U –force mozilla-1.2.1-26.i386.rpm

or whatever version is applicable.
Comment 9 Christopher Blizzard 2003-10-09 13:29:41 EDT
If you use galeon _as root_, right?
Comment 10 Ian Laurie 2003-10-09 16:28:03 EDT
Yes, I was root at the time.
Comment 11 Féliciano Matias 2004-04-03 10:13:47 EST
Seems fixed in FC2 T2.

Note You need to log in before you can comment on or make changes to this bug.