Bug 104295 - kinput2 too easy to kill
kinput2 too easy to kill
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kinput2 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
: 112763 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-12 04:34 EDT by Warren Togami
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-22 03:33:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch to support WM_DELETE_WINDOW. (2.43 KB, patch)
2003-10-23 02:18 EDT, Akira TAGOH
no flags Details | Diff

  None (edit)
Description Warren Togami 2003-09-12 04:34:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Very frequently users of kinput2 who are used to Microsoft or MacOS X IME are
confused by the choice dialog box that sometimes pops up when you hit the space
bar.  They often click the X at the top right of that kinput2 dialog, which
causes kinput2 to die completely.  They then need to logout and login completely
to get kinput2 back.

Would it be possible for kinput2 to "cancel" somehow when they click the X, as
killing it is never what was intended.

Version-Release number of selected component (if applicable):
kinput2-canna-wnn6-v3.1-10
Comment 1 Akira TAGOH 2003-09-12 04:44:02 EDT
Oh, you are right. it is too easy to kill kinput2.
Comment 2 Akira TAGOH 2003-10-23 02:18:41 EDT
Created attachment 95423 [details]
patch to support WM_DELETE_WINDOW.

when you press the close button, patched kinput2 just ignores this event,
because this patch is missing the cancellation code of the candidate window
right now.
I tried to implement that code, but there are some problems to do that. However
patched kinput2 won't be *too easy to kill* anymore.
Comment 3 Warren Togami 2003-11-04 02:58:50 EST
Did this patch make it in time for FC1?
Comment 4 Warren Togami 2003-12-14 04:34:20 EST
XIO:  fatal IO error 2 (No such file or directory) on X server ":0.0"
      after 437 requests (436 known processed) with 0 events remaining.

This happened to me on FC1 when I clicked the "X" on the kanji
candidate window.  Is this a related problem?
Comment 5 Akira TAGOH 2003-12-14 20:42:29 EST
Because the patch was not included in FC1's, unfortunately.
Comment 6 Akira TAGOH 2004-01-02 12:15:54 EST
*** Bug 112763 has been marked as a duplicate of this bug. ***
Comment 7 Akira TAGOH 2004-01-22 03:33:25 EST
This problem was fixed in v3.1-12. it will be included in the next
release.

Note You need to log in before you can comment on or make changes to this bug.