Bug 112763 - close button on the Candidate Selection window kills kinput2
close button on the Candidate Selection window kills kinput2
Status: CLOSED DUPLICATE of bug 104295
Product: Fedora
Classification: Fedora
Component: kinput2 (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
Bill Huang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-12-30 15:36 EST by Eido Inoue
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:00:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eido Inoue 2003-12-30 15:36:31 EST
Description of problem:
The Candidate Selection window that appears with certain Japanese
input methods (Canna, not FreeWnn) cannot be closed by clicking on the
close button.

Version-Release number of selected component (if applicable):
kinput2-canna-wnn6-v3.1-11

How reproducible:
always

Steps to Reproduce:
1. Inside gnome-terminal running in default Japanese environment
   (romaji input)with Canna running, press Shift-Space to turn on 
   editing.
3. Turn on kinput with Shift-Space, then type a romaji sequence in an
   input area (such as "sushi"), press the space bar twice-- the first
   time to convert, the second time to display alternate candidates.
3. Click on the close button of the "Candidate Selection" window.
4. Try turning kinput back on with shift-space.
  
Actual results:
kinput quits/crashes.

Expected results:
kinput should continue to function as if the person changed their mind
about selecting an alternate kanji candidate.

Additional info:
When kinput crashes, any app that had a connection to it (Mozilla,
OpenOffice, etc. gnome-terminal seems to be an exception) will need to
be closed and restarted. So in essence, if kinput crashes, it renders
any application that is using Japanese input useless for further input
until they are closed and restarted, even if kinput itself is restarted.
Comment 1 Akira TAGOH 2004-01-02 12:15:51 EST

*** This bug has been marked as a duplicate of 104295 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:00:32 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.