Bug 1043519 - BVT: smbd crashing while running IO tools on Linux cifs mount
Summary: BVT: smbd crashing while running IO tools on Linux cifs mount
Keywords:
Status: CLOSED DUPLICATE of bug 1046564
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba
Version: 2.1
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: RHGS 2.1.2
Assignee: Poornima G
QA Contact: Lalatendu Mohanty
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-16 14:27 UTC by Lalatendu Mohanty
Modified: 2015-05-13 16:31 UTC (History)
5 users (show)

Fixed In Version: glusterfs-3.4.0.53rhs
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-03 10:24:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Glusterfs logs (8.58 KB, application/x-gzip)
2013-12-16 14:34 UTC, Lalatendu Mohanty
no flags Details
Samba logs (6.62 KB, application/x-gzip)
2013-12-16 14:35 UTC, Lalatendu Mohanty
no flags Details

Description Lalatendu Mohanty 2013-12-16 14:27:28 UTC
Description of problem:

smbd is crashing while running dbench on Linux cifs mount. The test is passing but during it  smbd core is getting generated.

Below is the dbench command used for test.

DBENCH_BIN_PATH=${DBENCH_BIN_PATH:=/opt/qa/tools}
DBENCH_TIME=${DBENCH_TIME:=300}
DBENCH_CLIENTS=${DBENCH_CLIENTS:=10}

dbench -t $DBENCH_TIME -c $DBENCH_BIN_PATH/client.txt -s $DBENCH_CLIENTS

Version-Release number of selected component (if applicable):

samba-3.6.9-160.7.el6rhs.x86_64

How reproducible:
Always with BVT automation

Steps to Reproduce:
1. Mount glusterfs volume with cifs on a Linux client
2. run dbench with arguments as mentioned above
3.

Actual results:

2013/12/16 13:41:25.512068,  0] lib/fault.c:47(fault_report)
  ===============================================================
[2013/12/16 13:41:25.550886,  0] lib/fault.c:48(fault_report)
  INTERNAL ERROR: Signal 6 in pid 8223 (3.6.9-160.7.el6rhs)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2013/12/16 13:41:25.551189,  0] lib/fault.c:50(fault_report)
  
  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2013/12/16 13:41:25.551442,  0] lib/fault.c:51(fault_report)
  ===============================================================
[2013/12/16 13:41:25.551611,  0] lib/util.c:1117(smb_panic)
  PANIC (pid 8223): internal error
[2013/12/16 13:41:25.647780,  0] lib/util.c:1221(log_stack_trace)
  BACKTRACE: 11 stack frames:
   #0 smbd(log_stack_trace+0x1a) [0x7f8942b034fa]
   #1 smbd(smb_panic+0x2b) [0x7f8942b035cb]
   #2 smbd(+0x41a054) [0x7f8942af4054]
   #3 /lib64/libc.so.6(+0x32960) [0x7f893e9a0960]
   #4 /lib64/libc.so.6(gsignal+0x35) [0x7f893e9a08e5]
   #5 /lib64/libc.so.6(abort+0x175) [0x7f893e9a20c5]
   #6 /lib64/libc.so.6(+0x707f7) [0x7f893e9de7f7]
   #7 /lib64/libc.so.6(+0x76126) [0x7f893e9e4126]
   #8 /lib64/libc.so.6(+0x78c53) [0x7f893e9e6c53]
   #9 /usr/lib64/libtalloc.so.2(+0x2389) [0x7f893f545389]
   #10 /usr/lib64/libtalloc.so.2(+0x2323) [0x7f893f545323]
[2013/12/16 13:41:25.680441,  0] lib/fault.c:372(dump_core)
  dumping core in /var/log/samba/cores/smbd

Expected results:


Additional info:

Comment 1 Lalatendu Mohanty 2013-12-16 14:34:52 UTC
Created attachment 837252 [details]
Glusterfs logs

Glusterfs logs

Comment 2 Lalatendu Mohanty 2013-12-16 14:35:34 UTC
Created attachment 837253 [details]
Samba logs

Comment 3 Lalatendu Mohanty 2013-12-16 14:36:16 UTC
Comment on attachment 837253 [details]
Samba logs

Samba logs

Comment 7 Lalatendu Mohanty 2013-12-19 03:07:06 UTC
Not able to reproduce with the latest build 51. Yesterday's BVT also didn't reproduce this. Still I want to try some more attempts , before coming to conclusion.

Comment 9 Vivek Agarwal 2013-12-20 05:47:28 UTC
Have not seen this in the past couple of bvt runs.

Comment 10 Lalatendu Mohanty 2013-12-26 06:44:58 UTC
The smbd crash issue came during last two BVT runs. We are not able to recreate the issue manually, However Automation is hitting it intermittently. Hence reopening the bug.

Comment 11 Lalatendu Mohanty 2013-12-26 06:58:49 UTC
The latest crash came in below BVT build 

BVT Build version: glusterfs-server-3.4.0.52rhs-1387920125.el6.x86_64.rpm

Comment 12 Lalatendu Mohanty 2014-01-02 12:00:34 UTC
Can I please get the link of the patch which fixes this bug?

Comment 13 Poornima G 2014-01-02 12:11:34 UTC
Code posted at: 

https://code.engineering.redhat.com/gerrit/#/c/17893/

Comment 14 Lalatendu Mohanty 2014-01-02 14:04:20 UTC
I am not seeing this issue with recent BVT runs. Hence marking this as verified.

Comment 15 Poornima G 2014-01-03 10:24:03 UTC

*** This bug has been marked as a duplicate of bug 1046564 ***


Note You need to log in before you can comment on or make changes to this bug.