Bug 104367 - 'switchdesk' message always appears after entering password on login
Summary: 'switchdesk' message always appears after entering password on login
Status: CLOSED DUPLICATE of bug 104287
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: gdm   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-09-13 15:48 UTC by Andre Robatino
Modified: 2007-04-18 16:57 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:58:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Robatino 2003-09-13 15:48:40 UTC
Description of problem:
  Immediately after entering my password on the login screen, the following
message appears:

You have chosen Default System Session for this session.
If you wish to make Default System Session the default for
future sessions,
run the 'switchdesk' utility
(System->Desktop Switching Tool from the panel menu).

I have never changed any of the defaults.  Following the instructions doesn't
make the message go away, it always appears.

Version-Release number of selected component (if applicable):
gdm-2.4.4.0-2

How reproducible:
always

Steps to Reproduce:
1.  Enter username and password on login screen.

Actual results:
  "switchdesk' message appears.  I click on "OK" and log in as usual.

Expected results:
  Should be logged in without 'switchdesk' message.

Additional info:
  Downgrading to the original gdm-2.4.1.3-8 package from Severn eliminates the
problem.  When I upgrade back to gdm-2.4.4.0-2, it comes back.

Comment 1 Féliciano Matias 2003-09-13 17:11:15 UTC
Same problem here.
But I can't reproduce this with a new account.
However i fix this with the $HOME/.dmrc file.

.dmrc broken :
[Desktop]
Session=gnome.desktop

.dmrc that works :
[Desktop]
Session=Default.desktop


Comment 2 Elton Woo 2003-09-13 18:10:12 UTC
This is fixed with gdm-2.4.4.0-2 from rawhide. The login manager now
shows three choices: 1. Default 
                     #i.e. Gnome
                     2. KDE
                     3. Failsafe.
IMHO, this bug can be marked as "closed"

Comment 3 Kaj J. Niemi 2003-09-13 20:31:01 UTC
No, this is still a probem with gdm-2.4.4.0-2.



Comment 4 Kaj J. Niemi 2003-09-13 20:31:59 UTC
This is a duplicate bug of #104287.

Comment 5 Bill Nottingham 2003-09-15 22:42:30 UTC

*** This bug has been marked as a duplicate of 104287 ***

Comment 6 Red Hat Bugzilla 2006-02-21 18:58:34 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.