Bug 104373 - dragging window with mouse doesn't always work
dragging window with mouse doesn't always work
Status: CLOSED DUPLICATE of bug 104262
Product: Red Hat Raw Hide
Classification: Retired
Component: metacity (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-13 18:41 EDT by Andre Robatino
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2003-09-13 18:41:38 EDT
Description of problem:
  Upon upgrading to metacity-2.5.3-3, I found that when I left-click on the menu
bar of a window to drag it, sometimes it won't move.  If I immediately
left-click on it again, then it moves.  If after left-clicking on it once, if it
doesn't move, if I move the mouse pointer somewhere else and then left-click
again, the window suddenly jumps to the new location.  I verified that this is
associated with metacity by downgrading to the original Severn version
(metacity-2.4.55-5).  Upon restarting X, the problem was gone.  After upgrading
back to metacity-2.5.3-3 and restarting X, the problem came back.  I am using
the default Gnome desktop with all updates in the Severn updates channel up to
September 13.

Version-Release number of selected component (if applicable):
metacity-2.5.3-3

How reproducible:
Sometimes (although if one tries it with several different windows, it doesn't
take long to get it to happen at least once).

Steps to Reproduce:
1.  Try to drag a window by left-clicking on its menu bar and moving the mouse.
    
Actual results:
  Sometimes it won't move.  If it doesn't move, then if one moves the mouse
pointer somewhere else and clicks again, the window will suddenly jump to the
new location.

Expected results:
  The window should always move immediately in response to the mouse pointer.

Additional info:
Comment 1 Daniel Malmgren 2003-09-17 11:57:21 EDT
I think I'm experiencing the same bug. I get the following behaviour:

1. I click the window border (and after that I release the mouse button)
2. I move the pointer away from the border
3. After about one second the window jumps down to a position about 20 pixels
beneath the mouse pointer and after that it follows the pointer (still 20 pixels
beneath) until I click again somewhere else.

This happens about 50 percent of the times. It's very irritating when I click a
window border to raise that window I suddenly have that window moving all over
the screen.
Comment 2 Ralf Ertzinger 2003-09-24 18:49:46 EDT
All of the above confirmed on my system (Severn + current RawHide)
It seems to happen more often with certain windows, after starting Gnome and
opening an xterm, dragging the new window by it's title will almost never work
on the first try. Mozilla, for example, is almost always draggable, but the
window often follows the cursor when I just clicked the title to activate the
window.
Very annoying.
Comment 3 Andre Robatino 2003-10-03 12:11:21 EDT
  The new package metacity-2.6.2-1 fixed the problem for me.
Comment 4 Havoc Pennington 2003-10-03 16:47:35 EDT
Fixed in 2.6.2 for anyone else?
Comment 5 Ralf Ertzinger 2003-10-03 20:33:05 EDT
The "window does not respond when being dragged" seems fixed for me. There is
still an issue with clicking the title to raise the window, and the window then
sticking to the cursor, but I'll open a new bug for that.
Comment 6 Havoc Pennington 2003-10-04 01:12:31 EDT

*** This bug has been marked as a duplicate of 104262 ***
Comment 7 Red Hat Bugzilla 2006-02-21 13:58:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.