Bug 104392 - openoffice has absolute symlinks that should be relative
openoffice has absolute symlinks that should be relative
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: openoffice.org (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-14 14:52 EDT by Nathan G. Grennan
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-10 15:06:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2003-09-14 14:52:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030911
Galeon/1.3.8

Description of problem:
These symlink needs to be relative instead of absolute.

/usr/share/applications/openoffice-printeradmin.desktop
/usr/share/applications/openoffice-setup.desktop       
/usr/share/applications/redhat-drawing.desktop         
/usr/share/applications/redhat-math.desktop            
/usr/share/applications/redhat-presentations.desktop   
/usr/share/applications/redhat-spreadsheet.desktop     
/usr/share/applications/redhat-word-processor.desktop  

Version-Release number of selected component (if applicable):
openoffice-1.0.2-4

How reproducible:
Always

Steps to Reproduce:
1. cd /usr/share/applications
2. ls -al redhat-email.desktop

    

Actual Results:  Absolute symlink

Expected Results:  Relative symlink

Additional info:
Comment 1 Dan Williams 2003-09-17 11:40:46 EDT
What's the exact problem here?  What breaks because these symlinks are absolute
and not relative?  I'm not trying to sound like an ass, I'm just trying to
figure out what the bug here is...

Thanks, Dan
Comment 2 Nathan G. Grennan 2003-09-21 11:55:36 EDT
It has to do with copying /usr/share/applications to ~/.gnome2/vfolders in the
process to enable menu editing. With absolute symlinks they still point back to
/usr/share, while if they are relative they point to files in ~/.gnome2/vfolders.


I created 3-4 bug reports at once on this topic, and expected at someone to
question it.
Comment 3 Dan Williams 2004-02-10 15:06:55 EST
Menu editing in GNOME doesn't work and isn't supposed to work
anyway...  Closing as notabug.

Note You need to log in before you can comment on or make changes to this bug.