Bug 104399 - Huge uneeded .a in rpm
Huge uneeded .a in rpm
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: evolution (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-14 17:24 EDT by Ralph Loader
Modified: 2014-01-21 17:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-12-08 00:29:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralph Loader 2003-09-14 17:24:51 EDT
Recent evolution rpms (e.g., evolution-1.4.4-6.i386.rpm) contain lots of
apparently uneeded .a files.

One of these inparticular is *HUGE*

$ ls -l /usr/lib/evolution/1.4/components/libevolution-calendar.a
-rw-r--r--    1 root     root     40906900 Sep 11 16:36
/usr/lib/evolution/1.4/components/libevolution-calendar.a

This is more than half the bytes in the evolution package!

The .a in question appears to be pretty strangely linked.  It contains 2 copies
of another library (libdb.a).

I don't believe that any of the .a files are needed in the main evolution rpm. 
Possibly they could be moved to the -devel, although I suspect that these
components are designed to be dynamically loaded and that the .a files are of no
use whatsoever.
Comment 1 Michael Lee Yohe 2003-09-17 11:26:29 EDT
I built my own binary RPM using the 1.4.4-6 Rawhide Evolution source RPM.  My
file is not nearly that large:

$ ls -la /usr/lib/evolution/1.4/components/libevolution-calendar.a
-rw-r--r--    1 root     root      9599170 Sep 12 16:25
/usr/lib/evolution/1.4/components/libevolution-calendar.a

bzip2, with maximum compression, brings the file down to a hair over 3M.  I do
agree with you that this file seems to be out of place considering the shared
object is also within the same file.  Perhaps it should be moved to a
evolution-static package?
Comment 2 Jeremy Katz 2003-09-17 12:45:04 EDT
Moving them into -devel when 1.4.5 is released.  Probably huge due to a build
root getting an out of sync rpm config (and thus not stripping them)
Comment 3 Jeremy Katz 2003-10-06 16:05:44 EDT
Done in 1.4.5 package
Comment 4 Chris Ricker 2003-10-22 15:41:56 EDT
libdb.a is still included twice in
/usr/lib/evolution/1.4/components/libevolution-calendar.a, which is still 38
megs in size

1.4.5-5
Comment 5 Seth Vidal 2003-11-07 00:18:18 EST
Triaged -> Close. This is fixed in FC1
Comment 6 Chris Ricker 2003-11-07 07:20:57 EST
Don't close it. It's not fixed:

[kaboom@skuld kaboom]$ rpm -qf
/usr/lib/evolution/1.4/components/libevolution-calendar.a
evolution-devel-1.4.5-7
[kaboom@skuld kaboom]$ ls -l
/usr/lib/evolution/1.4/components/libevolution-calendar.a
-rw-r--r--    1 root     root     39749272 Oct 28 09:28
/usr/lib/evolution/1.4/components/libevolution-calendar.a
[kaboom@skuld kaboom]$ 
Comment 7 Seth Vidal 2003-11-07 08:02:49 EST
is it a problem if it is only in the evolution-devel package?
Comment 8 Chris Ricker 2003-11-07 08:05:54 EST
It doesn't need to be that big AFAICT -- it's so big at least in part
because libs are included twice in the archive. Maybe there's some
reason for that, though?
Comment 9 Dave Malcolm 2005-12-08 00:29:40 EST
Closing; fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.