Bug 1044010 - firefox seg faults when using the Admin Portal on RHEL 6.5.
Summary: firefox seg faults when using the Admin Portal on RHEL 6.5.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: firefox
Version: 6.5
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: rc
: 6.6
Assignee: Martin Stransky
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 1043430 1050146
TreeView+ depends on / blocked
 
Reported: 2013-12-17 15:33 UTC by wdaniel
Modified: 2018-12-06 15:35 UTC (History)
20 users (show)

Fixed In Version: firefox-24.3.0-2.el6_5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-11 14:20:36 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 647213 0 None None None Never

Description wdaniel 2013-12-17 15:33:52 UTC
Description of problem:

We had multiple cases open up around the same time both describing  scenarios in which Firefox was being used to browse the Admin Portal and during normal use Firefox would crash with  a seg fault message.

Version-Release number of selected component (if applicable):

RHEV 3.2
Firefox 24

How reproducible:
Unsure yet

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Cases were just opened so we are waiting on logs. Will attach them here as soon as they are received.

Comment 1 Evgheni Dereveanchin 2013-12-17 16:19:26 UTC
I want to note that I am able to reproduce this issue on a RHEL 6.5 client with firefox 24.2.0-1.el6_5, it looks like a browser problem, not something in RHEV-M (how can a web page be responsible for crashing the whole browser?)

Comment 4 Evgheni Dereveanchin 2013-12-17 17:16:51 UTC
changed product to firefox since the whole browser crashes which cannot normally be caused by a web application.

For now downgrading back to firefox 17 can be used as a workaround:
# yum downgrade firefox

Comment 15 Evgheni Dereveanchin 2013-12-19 12:04:49 UTC
Tested with clean profile + safe mode (only tested with clean profile before). No crash in safe mode. In the mean time, the spice plug-in is not disabled in safe mode and works if I toggle a remote console. This is the only plugin installed. Info in "Help > Troubleshooting" is exactly the same for both safe and non-safe mode.

What else could I test?

Comment 21 Martin Stransky 2013-12-19 14:44:14 UTC
Yes, we can reproduce it, thanks.

Comment 29 Martin Stransky 2014-01-13 11:48:37 UTC
Filled as https://errata.devel.redhat.com/advisory/16744

Comment 30 Martin Stransky 2014-02-11 14:20:36 UTC
Released as RHBA-2014:0084


Note You need to log in before you can comment on or make changes to this bug.