Bug 104406 - mozilla doesn't get prelinked.
mozilla doesn't get prelinked.
Status: CLOSED DUPLICATE of bug 106837
Product: Red Hat Linux Beta
Classification: Retired
Component: mozilla (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-15 05:18 EDT by David Woodhouse
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 06:10:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2003-09-15 05:18:04 EDT
mozilla lacks an rpath, hence when run standalone rather than from its shell
script, cannot find libmozjs.so.... which means it doesn't get prelinked.

Running 'LD_LIBRARY_PATH=/usr/lib/mozilla-1.4 prelink' works around the problem.
Adding an rpath would allow mozilla to get prelinked from the nightly cron job.
Comment 1 Christopher Aillon 2005-03-31 06:10:21 EST
slightly more info in another bug.  duping.

*** This bug has been marked as a duplicate of 106837 ***

Note You need to log in before you can comment on or make changes to this bug.