Bug 106837 - Mozilla doesn't prelink
Mozilla doesn't prelink
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
: 104406 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-10-11 10:45 EDT by Davide Moretti
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 06:14:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 288423 None None None Never

  None (edit)
Description Davide Moretti 2003-10-11 10:45:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1) Gecko/20031009

Description of problem:
after a prelink run, in the /var/log/prelink.log there is the followings:

/usr/sbin/prelink: /usr/lib/mozilla-1.4.1/mozilla-bin: Could not parse
`/usr/lib/mozilla-1.4.1/mozilla-bin: error while loading shared libraries:
libmozjs.so: cannot open shared object file: No such file or directory'
/usr/sbin/prelink: /usr/lib/mozilla-1.4.1/regchrome: Could not parse
`/usr/lib/mozilla-1.4.1/regchrome: error while loading shared libraries:
libxpcom.so: cannot open shared object file: No such file or directory'

libmozjs.so and libxpcom.so are in /usr/lib/mozilla-1.4.1

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. run /etc/cron.daily/prelink
2. examine /var/log/prelink.log
3.
    

Additional info:

Adding /usr/lib/mozilla-1.4.1 to /etc/ld.so.conf, and running ldconfig seems to
resolve the issue.

There are other errors in the prelink.log not related to this:

/usr/sbin/prelink: /usr/bin/emacs-21.3: COPY relocations don't point into .bss
or .sbss section
Prelinking /usr/lib/openoffice/program/getstyle-gnome
/usr/sbin/prelink: /usr/lib/openoffice/program/getstyle-gnome: Not enough room
to add .dynamic entry
Prelinking /usr/lib/openoffice/program/msgbox-gnome
/usr/sbin/prelink: /usr/lib/openoffice/program/msgbox-gnome: Not enough room to
add .dynamic entry

I think these need to be fixed changing something in the compilation phase of
these programs.
Comment 1 Jakub Jelinek 2003-10-11 12:00:43 EDT
FYI all these warnings just mean that some programs are not prelinked, prelinking
happens for the rest of the distro.
emacs will never be prelinkable until it gets rid of its crappy ELF dumper,
OO.o maintainer has been notified about the OO.o helper programs.
mozilla should be solved by adding -Wl,-rpath,'$ORIGIN'
to mozilla-bin link line (and epiphany by adding -Wl,-rpath,/usr/lib/mozilla-1.4.1
or whatever mozilla was it linked against).
Comment 2 Christopher Aillon 2005-03-31 06:10:29 EST
*** Bug 104406 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Aillon 2005-03-31 06:14:36 EST
Just filed upstream https://bugzilla.mozilla.org/show_bug.cgi?id=288423 

Note You need to log in before you can comment on or make changes to this bug.