Bug 104421 - ifup <bridge> doesn't work.
ifup <bridge> doesn't work.
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: initscripts (Show other bugs)
beta1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-15 09:50 EDT by David Woodhouse
Modified: 2014-03-16 22:38 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-10 11:11:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch (2.64 KB, patch)
2003-09-15 09:50 EDT, David Woodhouse
no flags Details | Diff

  None (edit)
Description David Woodhouse 2003-09-15 09:50:04 EDT
The ifup script has an 'if bridge then exit' where my patch had 
'if bridge and in_hotplug then exit'. 

So what was supposed to prevent a recursive invocation of ifup from being
triggered by the 'brctl addbr' line, in fact prevents it from working at all :)

The (soon to be) attached patch fixes this, cleans up the error handling in the
case where either brctl or the kernel support are absent, and causes radvd to
reload its config, since the MAC address of the bridge may change on addition or
removal of devices.
Comment 1 David Woodhouse 2003-09-15 09:50:41 EDT
Created attachment 94492 [details]
Patch
Comment 2 Bill Nottingham 2003-10-10 11:11:01 EDT
Fixed in CVS, will be in 7.37-1.

Note You need to log in before you can comment on or make changes to this bug.