Bug 104442 - WM crashes when switching virtual desktops shortly after login
WM crashes when switching virtual desktops shortly after login
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: metacity (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-09-15 13:12 EDT by Alexandre Oliva
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-04 01:13:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2003-09-15 13:12:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
Some times, but not always, after I log in (which starts two gnome-terminal
windows) and start a full-height GNU Emacs next to the right border on a
1920x1440 screen (I have an icon in my gnome panel that starts it), if I use
Ctrl-Alt-Rightarrow to switch to the second virtual desktop (where there's
nothing yet), the window manager crashes and automatically starts a few times. 
It has also happened some times on a 1600x1200 screen on my laptop.  Every time
it crashes, the GNU Emacs window moves down a bit, so I know the number of
crashes varies, and I easily notice when it happens.  Unfortunately, it's not
100% reproducible, but it has happened very often in the past few days.  Is
there any additional information I could provide to make it easier to track this
one down?

Version-Release number of selected component (if applicable):
metacity-2.5.3-3

How reproducible:
Sometimes

Steps to Reproduce:
1.Log in such that a gnome-terminal is started on desktops 1 and 4
2.Click on an icon that runs `emacs -geometry 80x106-0+0' (or 80x83 for 1600x1200)
3.Ctrl-Alt-rightarrow
    

Actual Results:  The window manager sometimes crashes, sometimes more than once

Expected Results:  It shouldn't

Additional info:

Non-default applets I have in my panel (that might be causing such problems?)
are the keyboard layout switcher and the weather applet.  I also have panel
auto-hide enabled.

One of the times I noticed the crash, I also noticed a run-away rhn applet
eating all CPU.  Since I'd logged in right after a reboot, it wasn't there
before, so it might be related, but it might be an entirely unrelated problem,
or even a consequence of the WM crash.
Comment 1 Havoc Pennington 2003-09-21 16:11:52 EDT
This is fixed in GNOME CVS, so basically we just have to make a new tarball
release and get it in the tree.

Michael I believe this is the same crash you were seeing.
Comment 2 Havoc Pennington 2003-10-04 01:13:06 EDT
Should be gone in 2.6.2
Comment 3 Alexandre Oliva 2003-10-06 09:57:35 EDT
Confirmed, I couldn't get this with 2.6.2-1 after several attempts, and it would
occur pretty much every time for me.  However, I've had WM crashes when closing
apps lately.  I still haven't been able to come up with a sequence of steps that
will trigger the bug, though.  In fact, I coudln't even come up with a sequence
of steps that will sometimes trigger it :-)  I'll file a separate bug.

Note You need to log in before you can comment on or make changes to this bug.