Bug 1044622 - [abrt] pptp: vector_destroy(): pptp killed by SIGABRT
Summary: [abrt] pptp: vector_destroy(): pptp killed by SIGABRT
Keywords:
Status: CLOSED DUPLICATE of bug 1108359
Alias: None
Product: Fedora
Classification: Fedora
Component: pptp
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:23c6a3654bdfa9d77a07eac2d8a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-18 17:10 UTC by Matthew Wilson
Modified: 2015-01-23 16:21 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-01-23 16:21:56 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (9.08 KB, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: cgroup (165 bytes, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: core_backtrace (3.43 KB, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: dso_list (398 bytes, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: environ (117 bytes, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: limits (1.29 KB, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: maps (2.42 KB, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: proc_pid_status (891 bytes, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details
File: var_log_messages (15.12 KB, text/plain)
2013-12-18 17:10 UTC, Matthew Wilson
no flags Details

Description Matthew Wilson 2013-12-18 17:10:38 UTC
Version-Release number of selected component:
pptp-1.8.0-1.fc20

Additional info:
reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        /sbin/pptp 90.155.97.141 --nolaunchpppd --loglevel 0 --logstring nm-pptp-service-1668
crash_function: vector_destroy
executable:     /usr/sbin/pptp
kernel:         3.11.10-301.fc20.x86_64
open_fds:       
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (5 frames)
 #5 vector_destroy at vector.c:58
 #6 pptp_conn_destroy at pptp_ctrl.c:459
 #7 callmgr_main at pptp_callmgr.c:307
 #8 launch_callmgr at pptp.c:527
 #9 open_callmgr at pptp.c:496

Comment 1 Matthew Wilson 2013-12-18 17:10:42 UTC
Created attachment 838469 [details]
File: backtrace

Comment 2 Matthew Wilson 2013-12-18 17:10:44 UTC
Created attachment 838470 [details]
File: cgroup

Comment 3 Matthew Wilson 2013-12-18 17:10:46 UTC
Created attachment 838471 [details]
File: core_backtrace

Comment 4 Matthew Wilson 2013-12-18 17:10:48 UTC
Created attachment 838472 [details]
File: dso_list

Comment 5 Matthew Wilson 2013-12-18 17:10:50 UTC
Created attachment 838473 [details]
File: environ

Comment 6 Matthew Wilson 2013-12-18 17:10:52 UTC
Created attachment 838474 [details]
File: limits

Comment 7 Matthew Wilson 2013-12-18 17:10:54 UTC
Created attachment 838475 [details]
File: maps

Comment 8 Matthew Wilson 2013-12-18 17:10:56 UTC
Created attachment 838476 [details]
File: proc_pid_status

Comment 9 Matthew Wilson 2013-12-18 17:10:58 UTC
Created attachment 838477 [details]
File: var_log_messages

Comment 10 salvador.gripoll 2014-09-19 11:13:33 UTC
Another user experienced a similar problem:

Estaba trabajando tranquilamente a través de la VPN PPTP y el daemon falló. Acto seguido no me dejo levantar de nuevo el tunel hasta que reinicié el equipo por completo.

Me sucede con frecuencia

reporter:       libreport-2.2.3
backtrace_rating: 4
cmdline:        pptp vpnterremark.ermestel.net --nolaunchpppd
crash_function: vector_destroy
executable:     /usr/sbin/pptp
kernel:         3.15.10-201.fc20.x86_64
open_fds:       
package:        pptp-1.8.0-1.fc20
reason:         pptp killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            0

Comment 11 Jaroslav Škarvada 2015-01-23 16:21:56 UTC
Probably dupe of bug 1108359.

*** This bug has been marked as a duplicate of bug 1108359 ***


Note You need to log in before you can comment on or make changes to this bug.