Bug 1044917 - configurating multi-backend fail in cinder
Summary: configurating multi-backend fail in cinder
Keywords:
Status: CLOSED DUPLICATE of bug 1031010
Alias: None
Product: RDO
Classification: Community
Component: openstack-cinder
Version: unspecified
Hardware: All
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Giulio Fidente
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-19 08:58 UTC by Zhengguang Ou
Modified: 2016-04-26 23:47 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-19 10:10:55 UTC


Attachments (Terms of Use)

Description Zhengguang Ou 2013-12-19 08:58:45 UTC
Description of problem:
Using RDO deploy Havana in centos6.5, when configurate multi-backend in cinder, the openstack-cinder-volume cann't restart, and the trace log as follow:
2013-12-18 18:32:05.795 5000 ERROR cinder.service [req-a51c1896-46a7-4109-8363-f7f16f714c0e None None] Unhandled exception
2013-12-18 18:32:05.795 5000 TRACE cinder.service Traceback (most recent call last):
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 228, in _start_child
2013-12-18 18:32:05.795 5000 TRACE cinder.service     self._child_process(wrap.server)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 205, in _child_process
2013-12-18 18:32:05.795 5000 TRACE cinder.service     launcher.run_server(server)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 96, in run_server
2013-12-18 18:32:05.795 5000 TRACE cinder.service     server.start()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/service.py", line 364, in start
2013-12-18 18:32:05.795 5000 TRACE cinder.service     self.binary)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/db/api.py", line 131, in service_get_by_args
2013-12-18 18:32:05.795 5000 TRACE cinder.service     return IMPL.service_get_by_args(context, host, binary)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/db/sqlalchemy/api.py", line 120, in wrapper
2013-12-18 18:32:05.795 5000 TRACE cinder.service     return f(*args, **kwargs)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/db/sqlalchemy/api.py", line 387, in service_get_by_args
2013-12-18 18:32:05.795 5000 TRACE cinder.service     result = model_query(context, models.Service).\
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/db/sqlalchemy/api.py", line 179, in model_query
2013-12-18 18:32:05.795 5000 TRACE cinder.service     session = kwargs.get('session') or get_session()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/openstack/common/db/sqlalchemy/session.py", line 376, in get_session
2013-12-18 18:32:05.795 5000 TRACE cinder.service     engine = get_engine(sqlite_fk=sqlite_fk)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/openstack/common/db/sqlalchemy/session.py", line 498, in get_engine
2013-12-18 18:32:05.795 5000 TRACE cinder.service     sqlite_fk=sqlite_fk)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib/python2.6/site-packages/cinder/openstack/common/db/sqlalchemy/session.py", line 601, in create_engine
2013-12-18 18:32:05.795 5000 TRACE cinder.service     engine.connect()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/engine/base.py", line 2472, in connect
2013-12-18 18:32:05.795 5000 TRACE cinder.service     return self._connection_cls(self, **kwargs)
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/engine/base.py", line 878, in __init__
2013-12-18 18:32:05.795 5000 TRACE cinder.service     self.__connection = connection or engine.raw_connection()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/engine/base.py", line 2558, in raw_connection
2013-12-18 18:32:05.795 5000 TRACE cinder.service     return self.pool.unique_connection()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/pool.py", line 183, in unique_connection
2013-12-18 18:32:05.795 5000 TRACE cinder.service     return _ConnectionFairy(self).checkout()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/pool.py", line 387, in __init__
2013-12-18 18:32:05.795 5000 TRACE cinder.service     rec = self._connection_record = pool._do_get()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/pool.py", line 741, in _do_get
2013-12-18 18:32:05.795 5000 TRACE cinder.service     con = self._create_connection()
2013-12-18 18:32:05.795 5000 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/pool.py", line 188, in _create_connection
2013-12-18 18:06:31.910 25883 TRACE cinder.service     return _ConnectionRecord(self)
2013-12-18 18:06:31.910 25883 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/pool.py", line 270, in __init__
2013-12-18 18:06:31.910 25883 TRACE cinder.service     self.connection = self.__connect()
2013-12-18 18:06:31.910 25883 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/pool.py", line 330, in __connect
2013-12-18 18:06:31.910 25883 TRACE cinder.service     connection = self.__pool._creator()
2013-12-18 18:06:31.910 25883 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/engine/strategies.py", line 80, in connect
2013-12-18 18:06:31.910 25883 TRACE cinder.service     return dialect.connect(*cargs, **cparams)
2013-12-18 18:06:31.910 25883 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/SQLAlchemy-0.7.8-py2.6-linux-x86_64.egg/sqlalchemy/engine/default.py", line 281, in connect
2013-12-18 18:06:31.910 25883 TRACE cinder.service     return self.dbapi.connect(*cargs, **cparams)
2013-12-18 18:06:31.910 25883 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/MySQLdb/__init__.py", line 81, in Connect
2013-12-18 18:06:31.910 25883 TRACE cinder.service     return Connection(*args, **kwargs)
2013-12-18 18:06:31.910 25883 TRACE cinder.service   File "/usr/lib64/python2.6/site-packages/MySQLdb/connections.py", line 187, in __init__
2013-12-18 18:06:31.910 25883 TRACE cinder.service     super(Connection, self).__init__(*args, **kwargs2)
2013-12-18 18:06:31.910 25883 TRACE cinder.service OperationalError: (OperationalError) (1045, "Access denied for user 'cinder'@'localhost' (using password: YES)") None None




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.configurating  cinder.conf follow this:http://docs.openstack.org/admin-guide-cloud/content//multi_backend.html
2./etc/init.d/openstack-cinder-volume restart


Actual results:


Expected results:


Additional info:

Comment 1 Giulio Fidente 2013-12-19 09:43:03 UTC
Sounds like a duplicate of bz #1031010. From commen 9 there: this is failing because all settings below the enabled_backends section are actually in the [nfs1] section of the ini file rather than default.  Move the [lvm1] and [nfs1] settings to the bottom of the file so that your sql_connection setting is in the [DEFAULT] section and things should work as expected.

Please update the bug or mark as duplicate if that works for you.

Comment 2 Zhengguang Ou 2013-12-19 10:10:55 UTC
Thanks,it works.

*** This bug has been marked as a duplicate of bug 1031010 ***


Note You need to log in before you can comment on or make changes to this bug.