Bug 1031010 - Cinder crashes when multiple backend is enabled
Cinder crashes when multiple backend is enabled
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
All Linux
unspecified Severity unspecified
: rc
: 4.0
Assigned To: Eric Harney
Yogev Rabl
storage
: Regression, Unconfirmed
: 1044917 (view as bug list)
Depends On: 978490
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-15 08:24 EST by Yogev Rabl
Modified: 2016-04-26 12:43 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Does not appear to be a bug, removing Doc Text so this doesn't get documented for beta.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 14:09:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
single cinder host (90.59 KB, text/x-log)
2013-11-15 08:24 EST, Yogev Rabl
no flags Details
all in one topology (90.59 KB, text/x-log)
2013-11-15 08:25 EST, Yogev Rabl
no flags Details
cinder with multiple back end (44.90 KB, text/plain)
2013-11-26 10:16 EST, Yogev Rabl
no flags Details

  None (edit)
Description Yogev Rabl 2013-11-15 08:24:31 EST
Created attachment 824542 [details]
single cinder host

Description of problem:
The Cinder's multiple backend feature cause the Cinder's services to fail due to an error connection to the MySQL. The feature doesn't work when it's an AIO topology and when the Cinder is on a different host.  

Version-Release number of selected component (if applicable):
openstack-nova-api-2013.2-4.el6ost.noarch
openstack-ceilometer-common-2013.2-1.el6ost.noarch
openstack-nova-network-2013.2-4.el6ost.noarch
python-django-openstack-auth-1.1.2-1.el6ost.noarch
openstack-dashboard-theme-2013.2-3.el6ost.noarch
openstack-ceilometer-collector-2013.2-1.el6ost.noarch
openstack-selinux-0.1.2-12.el6ost.noarch
openstack-glance-2013.2-1.el6ost.noarch
openstack-cinder-2013.2-2.el6ost.noarch
openstack-nova-common-2013.2-4.el6ost.noarch
openstack-ceilometer-compute-2013.2-1.el6ost.noarch
openstack-nova-console-2013.2-4.el6ost.noarch
openstack-nova-compute-2013.2-4.el6ost.noarch
openstack-nova-conductor-2013.2-4.el6ost.noarch
openstack-nova-novncproxy-2013.2-4.el6ost.noarch
openstack-nova-scheduler-2013.2-4.el6ost.noarch
openstack-dashboard-2013.2-3.el6ost.noarch
openstack-keystone-2013.2-1.el6ost.noarch
openstack-utils-2013.2-1.el6ost.noarch
openstack-nova-cert-2013.2-4.el6ost.noarch
redhat-access-plugin-openstack-4.0.0-0.el6ost.noarch
openstack-ceilometer-central-2013.2-1.el6ost.noarch
openstack-ceilometer-api-2013.2-1.el6ost.noarch
openstack-packstack-2013.2.1-0.9.dev840.el6ost.noarch

mysql-5.1.71-1.el6.x86_64
mysql-libs-5.1.71-1.el6.x86_64
mysql-server-5.1.71-1.el6.x86_64

RHEL 6.5

How reproducible:
100%

Steps to Reproduce:
1. configure multiple backend in the cinder.conf 
2. restart the Cinder services 
3.

Actual results:
Cinder services are dead.

Expected results:
Cinder services are running and the multiple backend is enabled.

Additional info:
Comment 1 Yogev Rabl 2013-11-15 08:25:20 EST
Created attachment 824543 [details]
all in one topology
Comment 2 Eric Harney 2013-11-18 10:35:23 EST
Both of the logs attached indicate authentication problems for mysql
cinder@localhost.  Is sql_connection / connection in cinder.conf set to
something that appears to be correct?
Comment 3 Eric Harney 2013-11-18 12:11:17 EST
How did you deploy an AIO topology with Cinder on a different host?
Comment 4 Eric Harney 2013-11-19 10:19:01 EST
Can you attach your cinder.conf file?
Comment 5 Yogev Rabl 2013-11-20 03:04:18 EST
(In reply to Eric Harney from comment #3)
> How did you deploy an AIO topology with Cinder on a different host?

If you mean, the topology with all the components in one host and the Cinder in another, then, I've installed it with packstack.
Comment 7 Ayal Baron 2013-11-20 09:27:26 EST
(In reply to Eric Harney from comment #4)
> Can you attach your cinder.conf file?

...
Comment 8 Yogev Rabl 2013-11-26 10:16:08 EST
Created attachment 829322 [details]
cinder with multiple back end

added the cinder.conf
Comment 9 Eric Harney 2013-11-26 14:06:36 EST
Yogev:  this is failing because all settings below the enabled_backends section are actually in the [nfs1] section of the ini file rather than default.  Move the [lvm1] and [nfs1] settings to the bottom of the file so that your sql_connection setting is in the [DEFAULT] section and things should work as expected.

Does not appear to be a bug.

--
conf snippet:

enabled_backends=lvm1,nfs1
[lvm1]
volume_driver=cinder.volume.drivers.lvm.LVMISCSIDriver
volume_backend_name=LVM_iSCSI
volume_group=cinder-volumes
[nfs1]
nfs_shares_config=/etc/cinder/shares.conf
volume_driver=cinder.volume.drivers.nfs.NfsDriver
volume_backend_name=NFS

sql_connection=mysql://cinder:pass@10.35.x.x/cinder
Comment 10 Zhengguang Ou 2013-12-19 05:10:55 EST
*** Bug 1044917 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.