Bug 104499 - problems installing on SATA hard disk
problems installing on SATA hard disk
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-16 10:08 EDT by Mikel Ward
Modified: 2015-01-04 17:03 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-10 23:48:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/tmp/syslog just before starting the partitioning tool (9.50 KB, text/plain)
2003-09-16 21:56 EDT, Mikel Ward
no flags Details
disk partition layout on my system (488 bytes, text/plain)
2003-09-16 21:59 EDT, Mikel Ward
no flags Details
output of parted /dev/hde print (537 bytes, text/plain)
2003-09-23 04:49 EDT, Mikel Ward
no flags Details

  None (edit)
Description Mikel Ward 2003-09-16 10:08:35 EDT
When I try to use the partitioning tool in Red Hat Linux 9.0.93
to perform a new installation, it complains there is not enough
free space to make the partition.

It seems the hard drive's physical size is not correctly detected,
as it is 80 GB, but the partioning tool thinks it's about 2 GB.

Mainboard: ASUS A7N8X nForce 2
Disk controller: Silicon Image SiI3112A
Disk drive: Seagate 80 GB SATA

I'll post exact details (BIOS settings, reported physical size,
etc.) if required.
Comment 1 Jeremy Katz 2003-09-16 11:06:30 EDT
Could you grab /tmp/syslog from the installer and attach it?
Comment 2 Mikel Ward 2003-09-16 21:53:22 EDT
After reporting this bug, I started a Gentoo Linux installation, and
was able to successfully read this hard drive and create disk
partitions using fdisk from the Gentoo boot CD.

Disk Druid is able to display these partitions, but I'm not sure if
it can manage them properly.
Comment 3 Mikel Ward 2003-09-16 21:56:24 EDT
Created attachment 94544 [details]
/tmp/syslog just before starting the partitioning tool

I have attached /tmp/syslog that was copied before I started the
partitioning tool.  It shows the relevant boot messages (you will
notice the hard drive is /dev/hde).
Comment 4 Mikel Ward 2003-09-16 21:59:03 EDT
Created attachment 94545 [details]
disk partition layout on my system

I have attached my partition layout (fdisk -l /dev/hde) so you
can see the reported disk geometry, the partitions that Disk Druid
should see fine, and the partitions that I am attempting to install
on.
Comment 5 Mikel Ward 2003-09-16 22:03:50 EDT
Once Disk Druid displays these partitions, I edit the partition
/dev/hde5 to tell the installer it must format the disk as ext3
(for some reason it defaulted to not formatting it) and to mount
it as "/".  After doing so, the installer proceeds to format the
partition (message is something like "Creating new filesystem on /"),
but hangs at 11% complete (no hard disk activity for over a minute,
system is unresponsive, can't switch to another virtual terminal).

Oddly, if I change to a shell before running the partitioning tool
and run "/usr/sbin/mkfs.ext3 /dev/hde5", it works fine.
Comment 6 Mikel Ward 2003-09-16 22:04:56 EDT
Changing summary to reflect other problems also mentioned here
(it seems there are more general problems installing on SATA drives).

Comment 7 Mikel Ward 2003-09-16 22:06:49 EDT
After formatting my root file system (/dev/hde5) manually using mkfs.ext3,
I go back to the installer and ensure it is not formatting /dev/hde5,
proceed to package selection, where I add "Development Tools" to a
"Personal Desktop" installation and continue the installation.

I then get as far as "Transferring install image to hard drive...", where
it hangs at 31%.
Comment 8 Jeremy Katz 2003-09-17 16:53:07 EDT
Can you also attach what parted sees the disk as looking like (run parted on the
drive and then type print)?
Comment 9 Mikel Ward 2003-09-23 04:49:13 EDT
Created attachment 94647 [details]
output of parted /dev/hde print

Also mentions geometry 9729/255/66 when parted is run interactively.
Comment 10 Mikel Ward 2003-09-23 21:51:25 EDT
FWIW, the FreeBSD installer says the geometry was reported as
155061/16/63, but says that's probably wrong
Comment 11 Jeremy Katz 2003-09-24 17:03:03 EDT
parted (and thus the installer) is finding things correctly.  Hangs are probably
kernel land.  But Test2 has a much newer libata codebase, and so should
hopefully work much better.  Leaving open until it can be verified against that.
Comment 12 Dave Jones 2004-11-19 21:02:04 EST
fixed in current releases ?
Comment 13 Mikel Ward 2004-11-20 23:45:48 EST
I have since performed a few successful Fedora installations, but I
now use a different partitioning scheme and do not rely on the Red Hat
installer to create them.

It's probably fixed, but I couldn't say so conclusively.

Note You need to log in before you can comment on or make changes to this bug.