Bug 104545 - usermode generates gdk_keyboard_grab errors
usermode generates gdk_keyboard_grab errors
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: usermode (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jindrich Novy
David Lawrence
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-09-16 19:04 EDT by Chris Ricker
Modified: 2013-07-02 18:58 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 04:55:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-09-16 19:04:58 EDT
[kaboom@skuld kaboom]$ up2date

** (up2date:22413): WARNING **: gdk_keyboard_grab returned 3
[kaboom@skuld kaboom]$ rpm -q up2date
up2date-3.9.28-2
[kaboom@skuld kaboom]$ 

The warning pops up when the GUI appears.... This is on a freshly up2date'd system
Comment 1 Adrian Likins 2003-09-17 15:14:27 EDT
hmmm, love those kind of bugs. Must be something bogus in the
glade file, I'll see what I can track down... I dont
see any references to that method in my code directly. 

Actually, it could possibly be in userhelper...
Do you see the same error if you run:

/usr/sbin/up2date ?

Dont see this on a 9 or taroon, box, will try
a rawhide box if I can. 
Comment 2 Chris Ricker 2003-09-22 17:55:20 EDT
I only see this intermittently, and I'm not sure why sometimes and not others. 
Comment 3 Chris Ricker 2003-10-15 18:39:20 EDT
Transferring to usermode -- this appears to happen when consolehelper pops up
the password dialog box only, so it's probably a bug there and not up2date
Comment 4 Chris Ricker 2003-10-17 12:32:15 EDT
Definitely a usermode problem, since r-c-network does the same thing

[kaboom@skuld kaboom]$ redhat-config-network

** (redhat-config-network:18718): WARNING **: gdk_keyboard_grab returned 3

Comment 5 Nalin Dahyabhai 2003-10-23 16:39:41 EDT
This error (which will change to actual text in 1.70 and later) indicates that
the window which attempted to grab the keyboard wasn't yet viewable (in the X
sense) at the time consolehelper-gtk tried to do this.

I can't duplicate this here to determine if it's safe to suppress the error or
not (it probably is, but I'd rather be sure).  Which other applications
(including window manager, session type, etc.) are running when you get this
error?  That may help reproduce this.
Comment 6 Chris Ricker 2003-11-04 00:33:33 EST
wm is openbox

only other apps are xterms and mozilla
Comment 7 Jindrich Novy 2005-04-08 04:55:18 EDT
I'm also unable to reproduce this. Please file a new bug against usermode if the
problem persists.

Note You need to log in before you can comment on or make changes to this bug.