Bug 1045704 - 99-resume.rules is generating a udev error [NEEDINFO]
Summary: 99-resume.rules is generating a udev error
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dracut
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: dracut-maint-list
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1063838 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-21 11:02 UTC by Sitsofe Wheeler
Modified: 2014-04-06 02:36 UTC (History)
20 users (show)

Fixed In Version: dracut-037-10.git20140402.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-04-06 02:36:41 UTC
sitsofe: needinfo? (dracut-maint-list)


Attachments (Terms of Use)
fix (1.19 KB, patch)
2013-12-24 12:55 UTC, Rodrigo de Farias Gomes
no flags Details | Diff
patch for modules.d/95resume/parse-resume.sh (1.66 KB, patch)
2014-01-10 16:36 UTC, Zbigniew Jędrzejewski-Szmek
no flags Details | Diff

Description Sitsofe Wheeler 2013-12-21 11:02:58 UTC
Description of problem:
After the system is booted the following an error message about 99-resume.rules having a bad key can be seen in the journal.

Version-Release number of selected component (if applicable):
dracut-034-64.git20131205.fc20.1.x86_64
kernel-3.11.10-301.fc20.x86_64

How reproducible:
Reproducible every time.

Steps to Reproduce:
1. Install Fedora 20.
2. Run
journalctl -b
and look for the red.

Actual results:
Dec 21 10:33:36 localhost.localdomain systemd-udevd[136]: unknown key '\nSYMLINK' in /etc/udev/rules.d/99-resume.rules:1
Dec 21 10:33:36 localhost.localdomain systemd-udevd[136]: invalid rule '/etc/udev/rules.d/99-resume.rules:1'

Expected results:
No udev error messages.

Additional info:
Others are reporting this error too:
http://thread.gmane.org/gmane.linux.redhat.fedora.testers/110041/focus=110064

Comment 1 Sitsofe Wheeler 2013-12-21 11:05:32 UTC
I forgot to say, there is also a little weirdness in /dev :
$ ls -l /dev/dev/resume 
lrwxrwxrwx. 1 root root 10 Dec 21 10:33 /dev/dev/resume -> ../../sda3
The symlink is broken because /sda3 doesn't exist.

Comment 2 Rodrigo de Farias Gomes 2013-12-24 12:55:31 UTC
Created attachment 841248 [details]
fix

This patch fix the bug.

Comment 3 Rodrigo de Farias Gomes 2013-12-24 18:31:26 UTC
The command:

printf -- "%s" " RUN+=\"/sbin/initqueue --finished --unique --name 00resume echo %%M:%%m > /sys/power/resume\"\n"

localized in line 62 of /usr/lib/dracut/modules.d/95resume/parse-resume.sh print:

RUN+="/sbin/initqueue --finished --unique --name 00resume echo %%M:%%m > /sys/power/resume"\n

with \n instead of a newline character.

The patch change the command to:

printf -- "%s\n" " RUN+=\"/sbin/initqueue --finished --unique --name 00resume echo %%M:%%m > /sys/power/resume\""

that print:

RUN+="/sbin/initqueue --finished --unique --name 00resume echo %%M:%%m > /sys/power/resume"

with a newline character after the ".


The unknown key '\nSYMLINK' is due the \n of the unpatched code. 

Sorry, english is not my preferred language...

Comment 4 Didier G 2013-12-25 23:14:00 UTC
I arrive on this bug because running rkhunter I get following warning:

[23:35:07] Checking for GasKit Rootkit...
[23:35:07]   Checking for file '/dev/dev/gaskit/sshd/sshdd'  [ Not found ]
[23:35:07]   Checking for directory '/dev/dev'               [ Found ]
[23:35:07]   Checking for directory '/dev/dev/gaskit'        [ Not found ]
[23:35:08]   Checking for directory '/dev/dev/gaskit/sshd'   [ Not found ]
[23:35:08] Warning: GasKit Rootkit                           [ Warning ]
[23:35:08]          Directory '/dev/dev' found

I assume this warning from rkhunter is a side effect of comment 1

Comment 5 Rodrigo de Farias Gomes 2013-12-26 00:31:43 UTC
(In reply to Didier G from comment #4)
> I arrive on this bug because running rkhunter I get following warning:
> 
> [23:35:07] Checking for GasKit Rootkit...
> [23:35:07]   Checking for file '/dev/dev/gaskit/sshd/sshdd'  [ Not found ]
> [23:35:07]   Checking for directory '/dev/dev'               [ Found ]
> [23:35:07]   Checking for directory '/dev/dev/gaskit'        [ Not found ]
> [23:35:08]   Checking for directory '/dev/dev/gaskit/sshd'   [ Not found ]
> [23:35:08] Warning: GasKit Rootkit                           [ Warning ]
> [23:35:08]          Directory '/dev/dev' found
> 
> I assume this warning from rkhunter is a side effect of comment 1

The /dev/dev/resume symbolic link bug (bug 1045116) is corrected upstream

http://git.kernel.org/cgit/boot/dracut/dracut.git/commit?id=bb1ba3a1ca9dd6284f6319eb197de4a757a7f99d

and is not related to error message about 99-resume.rules seen in journalctl -b.

Can you paste your comment in the bug 1045116? Thanks in advance

Comment 6 Zbigniew Jędrzejewski-Szmek 2014-01-10 16:36:53 UTC
Created attachment 848296 [details]
patch for modules.d/95resume/parse-resume.sh

This patch actually fixes the problem, not just the warning.

Comment 7 Steve Alexander 2014-01-11 06:19:52 UTC
I confirm this patch works as intended.

Comment 8 MaxiPunkt 2014-01-20 18:20:53 UTC
Hi there,

isn't this a duplicate of bug #1045116 ?
Moreover, it seems to have been fixed upstream, yesterday.

So could you please apply upstream patch?

Comment 9 Zbigniew Jędrzejewski-Szmek 2014-01-20 20:47:01 UTC
(In reply to MaxiPunkt from comment #8)
> isn't this a duplicate of bug #1045116 ?
No, it's a separate bug.

Comment 10 Zbigniew Jędrzejewski-Szmek 2014-02-11 14:02:51 UTC
*** Bug 1063838 has been marked as a duplicate of this bug. ***

Comment 12 Yu Watanabe 2014-02-17 08:47:41 UTC
I found and tried an update build of dracut at koji.
http://koji.fedoraproject.org/koji/buildinfo?buildID=492985

The updated package seems to be work well.
Why this update have not pushed to the update-testing repository?

Comment 13 Davide Repetto 2014-02-25 15:53:03 UTC
I downloaded and tested the packages from koji too and they work for me as well.

Comment 14 Michael Monreal 2014-04-01 19:15:47 UTC
dracut-034-64.git20131205.fc20.1.x86_64 still seems to be the latest official release?

Comment 15 Fedora Update System 2014-04-02 08:56:29 UTC
dracut-037-10.git20140402.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/dracut-037-10.git20140402.fc20

Comment 16 Fedora Update System 2014-04-03 04:02:28 UTC
Package dracut-037-10.git20140402.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dracut-037-10.git20140402.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-4704/dracut-037-10.git20140402.fc20
then log in and leave karma (feedback).

Comment 17 Fedora Update System 2014-04-06 02:36:41 UTC
dracut-037-10.git20140402.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.