Bug 1045842 - After deleting image failed ui display message: Disk gluster-test was successfully removed from domain gluster with storage failure
Summary: After deleting image failed ui display message: Disk gluster-test was success...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.5.0
Assignee: Sergey Gotliv
QA Contact: Ori Gofen
URL:
Whiteboard: storage
Depends On: 1116585 1124397
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-22 13:22 UTC by Nir Soffer
Modified: 2016-02-10 17:50 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:32:07 UTC
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 23956 None None None Never

Description Nir Soffer 2013-12-22 13:22:57 UTC
Description of problem:

Deletion of image failed (see http://gerrit.ovirt.org/#/c/22563/),
but engine display the confusing message:
 
    Disk gluster-test was successfully removed from domain gluster with storage failure

Version-Release number of selected component (if applicable):

ovirt-engine 5ccea20c205457f70cbd480f80455f600b386836

How reproducible:

Always


Steps to Reproduce:
1. Create disk on glusterfs domain
2. Delete disk

Actual results:

Clear error message about failure to delete the disk.

Comment 1 Allon Mureinik 2013-12-24 17:16:29 UTC
Sergey, can you take a look please? This looks the area you handled in 3.3.

Comment 2 Sergey Gotliv 2013-12-28 19:43:01 UTC
Nir,

Can you, please, attach relevant log files.

Comment 3 Sandro Bonazzola 2014-02-07 11:29:41 UTC
Please backport the patch to 3.4 branch or re-target to 3.5

Comment 4 Elad 2014-07-06 13:45:15 UTC
Cannot check due to https://bugzilla.redhat.com/show_bug.cgi?id=1116585

Comment 5 Ori Gofen 2014-09-02 13:32:05 UTC
verified on rc1.1

Comment 6 Sandro Bonazzola 2014-10-17 12:32:07 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.