Bug 1124397 - [oVirt-engine] Add glusterfs disk operation fails to complete
Summary: [oVirt-engine] Add glusterfs disk operation fails to complete
Keywords:
Status: CLOSED DUPLICATE of bug 1116585
Alias: None
Product: oVirt
Classification: Retired
Component: vdsm
Version: 3.5
Hardware: Unspecified
OS: Unspecified
high
urgent
Target Milestone: ---
: 3.5.0
Assignee: Dan Kenigsberg
QA Contact: Gil Klein
URL:
Whiteboard: gluster
Depends On:
Blocks: 1045842
TreeView+ depends on / blocked
 
Reported: 2014-07-29 12:12 UTC by Ori Gofen
Modified: 2016-02-10 19:28 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-01 16:26:29 UTC
oVirt Team: Gluster


Attachments (Terms of Use)
vdsm+engine logs (1.88 MB, application/gzip)
2014-07-29 12:12 UTC, Ori Gofen
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 30934 master MERGED fileSD: include gluster in getMountsList Never

Description Ori Gofen 2014-07-29 12:12:41 UTC
Created attachment 922134 [details]
vdsm+engine logs

Description of problem:

oVirt-engine fails to complete glusterfs disk creation.
the command does not get sent properly. 

2014-07-29 15:04:27,873 ERROR [org.ovirt.engine.core.vdsbroker.vdsbroker.HSMGetAllTasksStatusesVDSCommand] (DefaultQuartzScheduler_Worker-48) Failed in HSMGetAllTasksStatusesVDS method
2014-07-29 15:04:27,874 INFO  [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler_Worker-48) SPMAsyncTask::PollTask: Polling task 1cbf4087-f902-46dd-8598-24f325d61102 (Parent Command AddDisk, Parameters Type org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters) returned status finished, result 'cleanSuccess'.
2014-07-29 15:04:27,890 ERROR [org.ovirt.engine.core.bll.tasks.SPMAsyncTask] (DefaultQuartzScheduler_Worker-48) BaseAsyncTask::LogEndTaskFailure: Task 1cbf4087-f902-46dd-8598-24f325d61102 (Parent Command AddDisk, Parameters Type org.ovirt.engine.core.common.asynctasks.AsyncTaskParameters) ended with failure:
-- Result: cleanSuccess
-- Message: VDSGenericException: VDSErrorException: Failed to HSMGetAllTasksStatusesVDS, error = [Errno 2] No such file or directory: '/rhev/data-center/00000002-0002-0002-0002-000000000200/b8ae5843-02e4-405b-a346-c4f1f9aa3494/images/5a939551-5e95-4405-8760-25886d81de20', code = 100,




Version-Release number of selected component (if applicable):
beta.2

How reproducible:
100%

Steps to Reproduce:
1.create gluserfs disk

Actual results:
operation fails

Expected results:
operation should succeed

Additional info:

Comment 1 Allon Mureinik 2014-07-31 16:34:13 UTC
Fede, does this ring a bell?

-- Result: cleanSuccess
-- Message: VDSGenericException: VDSErrorException: Failed to HSMGetAllTasksStatusesVDS, error = [Errno 2] No such file or directory: '/rhev/data-center/00000002-0002-0002-0002-000000000200/b8ae5843-02e4-405b-a346-c4f1f9aa3494/images/5a939551-5e95-4405-8760-25886d81de20', code = 100,

Comment 2 Federico Simoncelli 2014-08-01 16:26:29 UTC

*** This bug has been marked as a duplicate of bug 1116585 ***


Note You need to log in before you can comment on or make changes to this bug.