Bug 1046259 - Qemu-img will prompt error and even core dump when creating libgfapi image
Summary: Qemu-img will prompt error and even core dump when creating libgfapi image
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: glusterfs
Version: 7.0
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: ---
Assignee: Poornima G
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1046564
TreeView+ depends on / blocked
 
Reported: 2013-12-24 09:24 UTC by Xiaomei Gao
Modified: 2015-03-26 11:29 UTC (History)
19 users (show)

Fixed In Version: glusterfs-3.6.0.41-1.el7
Doc Type: Bug Fix
Doc Text:
Previously, when executing an application linked with gfapi library, some debug messages appear in the standard error (stderr) stream when the log file was specified. Now, with this update, the gfapi library code has been fixed and the debug messages do not appear in the standard error (stderr) stream when the log file is specified.
Clone Of:
: 1046564 (view as bug list)
Environment:
Last Closed: 2015-03-26 11:29:22 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 3 Shyamsundar 2013-12-25 05:11:30 UTC
This looks like a manifestation of the issue being fixed here, http://review.gluster.org/#/c/6552/

Based on the working and non-working revisions provided, the changes to the code are (glusterfs-3.4.0.44rhs-1.el7.x86_64  -good : glusterfs-3.4.0.47.1u2rhs-1.el7  - bad),
http://review.gluster.org/6074
http://review.gluster.org/5388
http://review.gluster.org/6263 (current thought that this is causing the issue)
http://review.gluster.org/5936
http://review.gluster.org/6201

@poornima, can we validate the same?

Comment 6 Gowrishankar Rajaiyan 2014-01-27 12:21:14 UTC
[root@rhsqa-virt04 ~]# qemu-img create -f raw gluster://10.70.43.172/virt-vol/b.img 10G
Formatting 'gluster://10.70.43.172/virt-vol/b.img', fmt=raw size=10737418240 
[2014-01-27 11:13:50.343286] E [afr-common.c:4025:afr_notify] 0-virt-vol-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
[root@rhsqa-virt04 ~]# 


[root@rhsqa-virt04 ~]# qemu-img info /var/lib/libvirt/images/vms/b.img 
image: /var/lib/libvirt/images/vms/b.img
file format: raw
virtual size: 10G (10737418240 bytes)
disk size: 0
[root@rhsqa-virt04 ~]#

Note: The error message is tracked as part of bug 1029367#c3

Comment 8 Xiaomei Gao 2014-03-20 06:04:22 UTC
Create libgfapi image on glusterfs-3.4.0.54rhs-1.el7.x86_64 and hit the same error with comment #6.

[root@dell-op780-06 qemu-kvm]# /usr/bin/qemu-img create -f raw gluster://10.66.106.53:24007/qzhanggv0/storage2.raw 10G
Formatting 'gluster://10.66.106.53:24007/qzhanggv0/storage2.raw', fmt=raw size=10737418240 
[2014-03-20 05:58:21.539247] E [afr-common.c:4023:afr_notify] 0-qzhanggv0-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.

[root@dell-op780-06 qemu-kvm]# qemu info gluster://10.66.106.53:24007/qzhanggv0/storage2.raw
-bash: qemu: command not found
[root@dell-op780-06 qemu-kvm]# qemu-img info gluster://10.66.106.53:24007/qzhanggv0/storage2.raw
[2014-03-20 06:02:14.868236] E [afr-common.c:4023:afr_notify] 0-qzhanggv0-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
image: gluster://10.66.106.53:24007/qzhanggv0/storage2.raw
file format: raw
virtual size: 10G (10737418240 bytes)
disk size: 4.0K

Comment 9 Anjana Suparna Sriram 2014-03-24 11:53:12 UTC
Updated the doc text based on our discussion, Poornima. Can you please review the
Doc Text for accuracy and edit if necessary?

Comment 10 Poornima G 2014-03-25 10:56:11 UTC
Doc text looks good.

Comment 11 Poornima G 2014-03-25 11:00:32 UTC
Could you please try with lusterfs-3.5qa2-0.274.gitecc475d.el6_5.x86_64.rpm   build and see if the issue is still seen? The glusterfs-3.4.0.54rhs-1.el7 build doesn't have the fix in it.

Comment 12 Xiaomei Gao 2014-03-26 07:31:28 UTC
(In reply to Poornima G from comment #11)
> Could you please try with lusterfs-3.5qa2-0.274.gitecc475d.el6_5.x86_64.rpm 
> build and see if the issue is still seen? The glusterfs-3.4.0.54rhs-1.el7
> build doesn't have the fix in it.

I installed qemu* rpm packages, but libgfapi.so.0()(64bit) is needed. The build you gave us is "/usr/lib64/libgfapi.so.6", so could you rebuild a new one or what other workarounds?

[root@hp-z800-06 qemu-kvm]# rpm -ivh qemu-*
error: Failed dependencies:
libgfapi.so.0()(64bit) is needed by qemu-img-10:1.5.3-53.el7.x86_64
libgfapi.so.0()(64bit) is needed by qemu-kvm-10:1.5.3-53.el7.x86_64
libgfapi.so.0()(64bit) is needed by qemu-kvm-common-10:1.5.3-53.el7.x86_64

[root@hp-z800-06 qemu-kvm]# rpm -ql glusterfs-api-3.5qa2-0.274.gitecc475d.el6_5.x86_64 |grep libgfapi
/usr/lib64/libgfapi.so.6
/usr/lib64/libgfapi.so.6.0.0

Comment 13 Poornima G 2014-03-27 04:07:14 UTC
You could try the latest build glusterfs-3.5qa2-0.294.git00802b3.el6rhs, in this the libgfapi.so versioning is removed, and contains libgfapi.so.0()(64bit).

Comment 14 Xiaomei Gao 2014-03-27 10:14:55 UTC
(In reply to Poornima G from comment #13)
> You could try the latest build glusterfs-3.5qa2-0.294.git00802b3.el6rhs, in
> this the libgfapi.so versioning is removed, and contains
> libgfapi.so.0()(64bit).

Yes, this build works happily and doesn't prompt any error on RHEL7 host.

[root@dell-op780-06 glusterfs]# /usr/bin/qemu-img create -f raw gluster://10.66.106.53:24007/qzhanggv0/storage2.raw 10G
Formatting 'gluster://10.66.106.53:24007/qzhanggv0/storage2.raw', fmt=raw size=10737418240

[root@dell-op780-06 glusterfs]# rpm -qa | grep glusterfs
glusterfs-api-3.5qa2-0.294.git00802b3.el6rhs.x86_64
glusterfs-3.5qa2-0.294.git00802b3.el6rhs.x86_64
glusterfs-libs-3.5qa2-0.294.git00802b3.el6rhs.x86_64

Comment 24 Poornima G 2015-01-16 08:57:20 UTC
Fixed in Version glusterfs-3.6.0.41-1.el7

Comment 25 SATHEESARAN 2015-01-21 08:57:27 UTC
Tested this bug with RHEL 7.1 nightly (http://download.devel.redhat.com/composes/nightly/RHEL-7.1-20150116.n.0/ ) and glusterfs-3.6.0.42-1.el7rhs (http://download.devel.redhat.com/brewroot/packages/glusterfs/3.6.0.42/1.el7rhs/x86_64/)

Creating image using QEMU glusterfs driver works well but with warning message.
This warning message issue is tracked in this bug 1029367

1. Creating a RAW Image
------------------------
[~]# qemu-img create -f raw gluster://10.70.36.34/vmstore/vm2.img 1G
Formatting 'gluster://10.70.36.34/vmstore/vm2.img', fmt=raw size=1073741824 
[2015-01-21 08:46:52.777039] E [MSGID: 108006] [afr-common.c:4293:afr_notify] 0-vmstore-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.

2. Creating a QCOW2 Image
--------------------------
[root@rhs-client15 ~]# qemu-img create -f qcow2 gluster://10.70.36.34/vmstore/vm2.img 10GFormatting 'gluster://10.70.36.34/vmstore/vm2.img', fmt=qcow2 size=10737418240 encryption=off cluster_size=65536 lazy_refcounts=off 
[2015-01-21 08:48:52.610993] E [MSGID: 108006] [afr-common.c:4293:afr_notify] 0-vmstore-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
[2015-01-21 08:48:52.860575] E [MSGID: 108006] [afr-common.c:4293:afr_notify] 0-vmstore-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
[2015-01-21 08:48:53.009779] E [MSGID: 108006] [afr-common.c:4293:afr_notify] 0-vmstore-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.

3. Creating a QCOW2 Image with preallocation=metadata
------------------------------------------------------
[root@rhs-client15 ~]# qemu-img create -f qcow2 -o preallocation=metadata gluster://10.70.36.34/vmstore/vm3.img 10G
Formatting 'gluster://10.70.36.34/vmstore/vm3.img', fmt=qcow2 size=10737418240 encryption=off cluster_size=65536 preallocation='metadata' lazy_refcounts=off 
[2015-01-21 08:48:30.559665] E [MSGID: 108006] [afr-common.c:4293:afr_notify] 0-vmstore-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
[2015-01-21 08:48:30.811013] E [MSGID: 108006] [afr-common.c:4293:afr_notify] 0-vmstore-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.
[2015-01-21 08:48:31.059631] E [MSGID: 108006] [afr-common.c:4293:afr_notify] 0-vmstore-replicate-0: All subvolumes are down. Going offline until atleast one of them comes back up.

4. Checking/Verifying Images from the fuse mount
--------------------------------------------------
[~]# mount.glusterfs 10.70.36.34:vmstore /mnt

[~]# ls /mnt -1
vm1.img
vm2.img
vm3.img

[~]# qemu-img info /mnt/vm2.img 
image: /mnt/vm2.img
file format: qcow2
virtual size: 10G (10737418240 bytes)
disk size: 193K
cluster_size: 65536
Format specific information:
    compat: 1.1
    lazy refcounts: false

[~]# qemu-img info /mnt/vm3.img 
image: /mnt/vm3.img
file format: qcow2
virtual size: 10G (10737418240 bytes)
disk size: 2.2M
cluster_size: 65536
Format specific information:
    compat: 1.1
    lazy refcounts: false

[~]# ls -al /mnt
total 968057
drwxr-xr-x.  3 qemu qemu          85 Jan 21 14:18 .
dr-xr-xr-x. 17 root root        4096 Jan 21 12:26 ..
-rw-------.  1 qemu qemu 21474836480 Jan 21 13:39 vm1.img
-rw-------.  1 root root      197120 Jan 21 14:18 vm2.img
-rw-------.  1 root root 10739318784 Jan 21 14:18 vm3.img

Based on the test, there is no issue while creating images using qemu glusterfs driver ( using libgfapi ).

Marking this bug as VERIFIED based on the test


Note You need to log in before you can comment on or make changes to this bug.