Bug 1046355 - incosistentupdates list
Summary: incosistentupdates list
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-24 20:40 UTC by Gianluca Sforna
Modified: 2014-04-25 06:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-01-02 08:05:05 UTC
Type: Bug


Attachments (Terms of Use)

Description Gianluca Sforna 2013-12-24 20:40:05 UTC
I am not sure this is intended behavior, but there is a different list of updates if I run:

dnf update

compared to 

sudo dnf update

for the records, comparing the list of updates with yum, it seems the first form got the list right, while the sudo form contains a just a subset of the available updates.

Comment 1 Ales Kozumplik 2014-01-02 08:05:05 UTC
Hello, this is the expected behavior---each version works with different metadata. If one waits for the metadata to come in sync (after some time or by forcing them), the output will be the same.

Comment 2 Ales Kozumplik 2014-04-25 06:28:18 UTC
*** Bug 1090117 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.