Bug 1046707 - [abrt] evolution-data-server: g_thread_new(): evolution-calendar-factory killed by SIGTRAP
Summary: [abrt] evolution-data-server: g_thread_new(): evolution-calendar-factory kill...
Keywords:
Status: CLOSED DUPLICATE of bug 995177
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5db19343e37edbc49808e291d95...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-26 17:02 UTC by Adam Stein
Modified: 2014-06-02 10:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 10:09:29 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (38.76 KB, text/plain)
2013-12-26 17:02 UTC, Adam Stein
no flags Details
File: cgroup (154 bytes, text/plain)
2013-12-26 17:02 UTC, Adam Stein
no flags Details
File: core_backtrace (8.70 KB, text/plain)
2013-12-26 17:02 UTC, Adam Stein
no flags Details
File: dso_list (16.40 KB, text/plain)
2013-12-26 17:02 UTC, Adam Stein
no flags Details
File: environ (689 bytes, text/plain)
2013-12-26 17:02 UTC, Adam Stein
no flags Details
File: limits (1.29 KB, text/plain)
2013-12-26 17:02 UTC, Adam Stein
no flags Details
File: maps (179.12 KB, text/plain)
2013-12-26 17:03 UTC, Adam Stein
no flags Details
File: open_fds (731 bytes, text/plain)
2013-12-26 17:03 UTC, Adam Stein
no flags Details
File: proc_pid_status (945 bytes, text/plain)
2013-12-26 17:03 UTC, Adam Stein
no flags Details

Description Adam Stein 2013-12-26 17:02:40 UTC
Version-Release number of selected component:
evolution-data-server-3.8.5-6.fc19

Additional info:
reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: g_thread_new
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.12.5-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: Dec 26 10:53:39 zookeeper abrt-hook-ccpp[27838]: Saved core dump of pid 2766 (/usr/libexec/evolution-calendar-factory) to /var/tmp/abrt/ccpp-2013-12-26-10:53:28-2766 (5889167360 bytes)

Truncated backtrace:
Thread no. 0 (10 frames)
 #2 g_thread_new at gthread.c:839
 #3 impl_DataCalView_start at e-data-cal-view.c:195
 #4 e_gdbus_marshallers_BOOLEAN__OBJECT at e-gdbus-marshallers.c:124
 #9 e_gdbus_stub_handle_method_call at e-gdbus-templates.c:679
 #10 call_in_idle_cb at gdbusconnection.c:4737
 #15 dbus_server_run_server at e-dbus-server.c:222
 #16 ffi_call_unix64 at ../src/x86/unix64.S:76
 #17 ffi_call at ../src/x86/ffi64.c:522
 #18 g_cclosure_marshal_generic_va at gclosure.c:1550
 #19 _g_closure_invoke_va at gclosure.c:840

Potential duplicate: bug 963892

Comment 1 Adam Stein 2013-12-26 17:02:44 UTC
Created attachment 841993 [details]
File: backtrace

Comment 2 Adam Stein 2013-12-26 17:02:46 UTC
Created attachment 841994 [details]
File: cgroup

Comment 3 Adam Stein 2013-12-26 17:02:48 UTC
Created attachment 841995 [details]
File: core_backtrace

Comment 4 Adam Stein 2013-12-26 17:02:51 UTC
Created attachment 841996 [details]
File: dso_list

Comment 5 Adam Stein 2013-12-26 17:02:55 UTC
Created attachment 841997 [details]
File: environ

Comment 6 Adam Stein 2013-12-26 17:02:59 UTC
Created attachment 841998 [details]
File: limits

Comment 7 Adam Stein 2013-12-26 17:03:12 UTC
Created attachment 841999 [details]
File: maps

Comment 8 Adam Stein 2013-12-26 17:03:13 UTC
Created attachment 842000 [details]
File: open_fds

Comment 9 Adam Stein 2013-12-26 17:03:15 UTC
Created attachment 842001 [details]
File: proc_pid_status

Comment 10 Adam Stein 2014-01-11 19:25:36 UTC
Another user experienced a similar problem:

Just reading email and the backend quit

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: g_thread_new
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.12.6-200.fc19.x86_64
package:        evolution-data-server-3.8.5-6.fc19
reason:         evolution-calendar-factory killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 11 Adam Stein 2014-05-30 16:27:24 UTC
Another user experienced a similar problem:

Evolution was just running, nothing was happening from me.  Maybe an evolution background process?

reporter:       libreport-2.2.1
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: g_thread_new
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.14.4-100.fc19.x86_64
package:        evolution-data-server-3.8.5-6.fc19
reason:         evolution-calendar-factory killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 12 Milan Crha 2014-06-02 10:09:29 UTC
Thanks for a bug report. I think this is pretty much the same issue as bug #995177, thus I mark this as a duplicate of it. You are right that this is a background evolution process issue, the calendar factory.

*** This bug has been marked as a duplicate of bug 995177 ***


Note You need to log in before you can comment on or make changes to this bug.