Bug 995177 - [abrt] Error creating thread: Resource temporarily unavailable
[abrt] Error creating thread: Resource temporarily unavailable
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-ews (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:7898ea0317d80f02a1f1fa60b2e...
:
: 996234 998146 1011655 1040176 1040238 1040247 1040551 1040629 1040633 1041568 1046707 1050984 1051770 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-08 13:32 EDT by Mikhail
Modified: 2014-11-20 10:34 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 04:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (66.33 KB, text/plain)
2013-08-08 13:32 EDT, Mikhail
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-08 13:32 EDT, Mikhail
no flags Details
File: core_backtrace (46.31 KB, text/plain)
2013-08-08 13:32 EDT, Mikhail
no flags Details
File: dso_list (27.23 KB, text/plain)
2013-08-08 13:32 EDT, Mikhail
no flags Details
File: environ (3.05 KB, text/plain)
2013-08-08 13:32 EDT, Mikhail
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-08 13:32 EDT, Mikhail
no flags Details
File: maps (133.17 KB, text/plain)
2013-08-08 13:33 EDT, Mikhail
no flags Details
File: open_fds (2.61 KB, text/plain)
2013-08-08 13:33 EDT, Mikhail
no flags Details
File: proc_pid_status (942 bytes, text/plain)
2013-08-08 13:33 EDT, Mikhail
no flags Details
File: var_log_messages (13.00 KB, text/plain)
2013-08-08 13:33 EDT, Mikhail
no flags Details
evolution screenshot (82.47 KB, image/png)
2013-08-11 12:51 EDT, Mikhail
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 731554 None None None Never

  None (edit)
Description Mikhail 2013-08-08 13:32:33 EDT
Version-Release number of selected component:
evolution-3.8.4-2.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        evolution
crash_function: g_logv
executable:     /usr/bin/evolution
kernel:         3.10.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_logv at /lib64/libglib-2.0.so.0
 #1 g_log at /lib64/libglib-2.0.so.0
 #2 g_thread_new at /lib64/libglib-2.0.so.0
 #3 ews_unref_in_thread at e-ews-connection.c:190
 #4 ews_active_job_done at e-ews-connection.c:472
 #5 ews_response_cb at e-ews-connection.c:591
 #6 soup_session_process_queue_item at soup-session.c:1858
 #7 async_run_queue at soup-session.c:1896
 #8 idle_run_queue at soup-session.c:1930
 #9 g_main_context_dispatch at /lib64/libglib-2.0.so.0
Comment 1 Mikhail 2013-08-08 13:32:37 EDT
Created attachment 784500 [details]
File: backtrace
Comment 2 Mikhail 2013-08-08 13:32:40 EDT
Created attachment 784501 [details]
File: cgroup
Comment 3 Mikhail 2013-08-08 13:32:44 EDT
Created attachment 784502 [details]
File: core_backtrace
Comment 4 Mikhail 2013-08-08 13:32:49 EDT
Created attachment 784503 [details]
File: dso_list
Comment 5 Mikhail 2013-08-08 13:32:53 EDT
Created attachment 784504 [details]
File: environ
Comment 6 Mikhail 2013-08-08 13:32:56 EDT
Created attachment 784505 [details]
File: limits
Comment 7 Mikhail 2013-08-08 13:33:00 EDT
Created attachment 784506 [details]
File: maps
Comment 8 Mikhail 2013-08-08 13:33:03 EDT
Created attachment 784507 [details]
File: open_fds
Comment 9 Mikhail 2013-08-08 13:33:07 EDT
Created attachment 784508 [details]
File: proc_pid_status
Comment 10 Mikhail 2013-08-08 13:33:11 EDT
Created attachment 784509 [details]
File: var_log_messages
Comment 11 Milan Crha 2013-08-09 00:38:55 EDT
Thanks for a bug report. I see in the backtrace that this happened when evolution-ews tried to create a new thread, which failed for some reason. Unfortunately, ABRT didn't catch that reason, and I do not see any clue from the other files which would suggest what could fail. The application has opened only few threads, same as opened file handles is pretty low, only about 36 file handles.

Do you see this after specific steps, please?
Comment 12 Mikhail 2013-08-11 12:47:59 EDT
[mikhail@localhost ~]$ evolution

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed
Created new window in existing browser session.
Created new window in existing browser session.

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed
Created new window in existing browser session.

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2400): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed
evolution-shell-Message: Network disconnected.  Forced offline.
evolution-shell-Message: Connection established.  Going online.

(evolution:2400): evolution-mail-WARNING **: Failed to refresh folder 'm.gavrilov@citrus-it.ru: Inbox': Operation Cancelled
Created new window in existing browser session.

(evolution:2400): GLib-ERROR **: creating thread '': Error creating thread: Resource temporarily unavailable
Trace/breakpoint trap (core dumped)
Comment 13 Mikhail 2013-08-11 12:51:00 EDT
After it restarted evolution still not work. I see Loading... message below my 'm.gavrilov@citrus-it.ru' mailbox and nothing happens. Only reboot helps...
Comment 14 Mikhail 2013-08-11 12:51:45 EDT
Created attachment 785420 [details]
evolution screenshot
Comment 15 Mikhail 2013-08-11 23:05:14 EDT
[mikhail@localhost ~]$ evolution

(evolution:2213): GLib-GIO-CRITICAL **: g_file_info_get_content_type: assertion `G_IS_FILE_INFO (info)' failed

(evolution:2213): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(evolution:2213): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed

(evolution:2213): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2213): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2213): libebook-contacts-CRITICAL **: e_contact_get: assertion `contact && E_IS_CONTACT (contact)' failed

(evolution:2213): libeutil-CRITICAL **: e_contact_store_get_contact: assertion `ITER_IS_VALID (contact_store, iter)' failed
DWPBase: /home/mikhail/.config/libreoffice/4/user/uno_packages/cache/uno_packages/luq0mqw6.tmp_/orfo4ooo-linux.oxt/base/../base/DWPBase.bin
DWPBase: /home/mikhail/.config/libreoffice/4/user/uno_packages/cache/uno_packages/luq0mqw6.tmp_/orfo4ooo-linux.oxt/base/../base/DWPBase.bin

(evolution:2213): GLib-ERROR **: creating thread '': Error creating thread: Resource temporarily unavailable
Trace/breakpoint trap (core dumped)
[mikhail@localhost ~]$ evolution

(evolution:19396): GLib-GIO-CRITICAL **: g_file_info_get_content_type: assertion `G_IS_FILE_INFO (info)' failed

(evolution:19396): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
[1:1:0812/090126:FATAL:sandbox_bpf.cc(274)] fork() failed unexpectedly
[19535:19535:0812/090142:ERROR:platform_thread_posix.cc(127)] pthread_create: Resource temporarily unavailable

(evolution:19396): GLib-ERROR **: creating thread '': Error creating thread: Resource temporarily unavailable
Trace/breakpoint trap (core dumped)
[mikhail@localhost ~]$ evolution

(evolution:19812): GLib-ERROR **: creating thread '': Error creating thread: Resource temporarily unavailable
Trace/breakpoint trap (core dumped)
Comment 16 Milan Crha 2013-08-12 01:47:25 EDT
(In reply to Mikhail from comment #15)
> ....
> [1:1:0812/090126:FATAL:sandbox_bpf.cc(274)] fork() failed unexpectedly
> [19535:19535:0812/090142:ERROR:platform_thread_posix.cc(127)]
> pthread_create: Resource temporarily unavailable
> 
> (evolution:19396): GLib-ERROR **: creating thread '': Error creating thread:
> Resource temporarily unavailable
> Trace/breakpoint trap (core dumped)
> [mikhail@localhost ~]$ evolution
> 
> (evolution:19812): GLib-ERROR **: creating thread '': Error creating thread:
> Resource temporarily unavailable
> Trace/breakpoint trap (core dumped)

Thanks for the update. The above errors are causing the trouble. I suppose from them the error is quite low in the stack, like in kernel, but I do not know the underlying code much. I'm moving this to GLib, to get an opinion from their side.
Comment 17 Milan Crha 2013-08-13 03:11:21 EDT
*** Bug 996234 has been marked as a duplicate of this bug. ***
Comment 18 Mikhail 2013-08-17 05:34:07 EDT
$ evolution

(evolution:2252): GLib-GIO-CRITICAL **: g_file_info_get_content_type: assertion `G_IS_FILE_INFO (info)' failed

(evolution:2252): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(evolution:2252): GLib-GIO-CRITICAL **: g_file_info_get_content_type: assertion `G_IS_FILE_INFO (info)' failed

(evolution:2252): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x36f71f0 is mapped but not visible

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x36f71f0 is mapped but not visible

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x36f71f0 is mapped but visible=0 child_visible=1 parent GtkBox 0x3ec5c90 mapped=1

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x36f71f0 is mapped but not visible

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x36f71f0 is mapped but visible=0 child_visible=1 parent GtkBox 0x3ec5c90 mapped=1
DWPBase: /home/mikhail/.config/libreoffice/4/user/uno_packages/cache/uno_packages/luq0mqw6.tmp_/orfo4ooo-linux.oxt/base/../base/DWPBase.bin
** Message: console message: mail://1370695704.1835.5/desktop/Inbox/AAMkADM3MTQ2MTEyLTZjYzItNGY0ZS04ZGJmLTQ0Yzc3ZTUxZjg4ZQBGAAAAAADHbxaIUo7TRZMcZbnoBQvhBwAQmullzkq8SJBuVdAticoTAFtmvkMdAAATvkPzHvSERYVWWuBXIIzIAAAAB8HgAAA%3D?part_id=.message.alternative-prefer-plain.1.text_html&mode=2&formatter_default_charset=&formatter_charset= @5: Viewport argument value "device-width;" for key "width" is invalid, and has been ignored. Note that ';' is not a separator in viewport values. The list should be comma-separated.

** Message: console message: mail://1370695704.1835.5/desktop/Inbox/AAMkADM3MTQ2MTEyLTZjYzItNGY0ZS04ZGJmLTQ0Yzc3ZTUxZjg4ZQBGAAAAAADHbxaIUo7TRZMcZbnoBQvhBwAQmullzkq8SJBuVdAticoTAFtmvkMdAAATvkPzHvSERYVWWuBXIIzIAAAAB8HgAAA%3D?part_id=.message.alternative-prefer-plain.1.text_html&mode=2&formatter_default_charset=&formatter_charset= @5: Viewport argument value "1.0;" for key "initial-scale" was truncated to its numeric prefix. Note that ';' is not a separator in viewport values. The list should be comma-separated.

** Message: console message: mail://1370695704.1835.5/desktop/Inbox/AAMkADM3MTQ2MTEyLTZjYzItNGY0ZS04ZGJmLTQ0Yzc3ZTUxZjg4ZQBGAAAAAADHbxaIUo7TRZMcZbnoBQvhBwAQmullzkq8SJBuVdAticoTAFtmvkMdAAATvkPzHvSERYVWWuBXIIzIAAAAB8HgAAA%3D?part_id=.message.alternative-prefer-plain.1.text_html&mode=2&formatter_default_charset=&formatter_charset= @5: Viewport argument value "1.0;" for key "maximum-scale" was truncated to its numeric prefix. Note that ';' is not a separator in viewport values. The list should be comma-separated.


(evolution:2252): evolution-mail-WARNING **: Failed to request http://tracker.nmp1.com/WBS (code 500)
** Message: console message: mail://1370695704.1835.5/desktop/Inbox/AAMkADM3MTQ2MTEyLTZjYzItNGY0ZS04ZGJmLTQ0Yzc3ZTUxZjg4ZQBGAAAAAADHbxaIUo7TRZMcZbnoBQvhBwAQmullzkq8SJBuVdAticoTAFtmvkMdAAATvkPzHvSERYVWWuBXIIzIAAAAB70QAAA%3D?part_id=.message.related.0.alternative-prefer-plain.1.text_html&mode=2&formatter_default_charset=&formatter_charset= @54: Not allowed to load local resource: file:///C:/Program%20Files/Common%20Files/Microsoft%20Shared/Stationery/SoftBlue.jpg

** Message: console message: mail://1370695704.1835.5/desktop/Inbox/AAMkADM3MTQ2MTEyLTZjYzItNGY0ZS04ZGJmLTQ0Yzc3ZTUxZjg4ZQBGAAAAAADHbxaIUo7TRZMcZbnoBQvhBwAQmullzkq8SJBuVdAticoTAFtmvkMdAAATvkPzHvSERYVWWuBXIIzIAAAAB70MAAA%3D?part_id=.message.related.0.alternative-prefer-plain.1.text_html&mode=2&formatter_default_charset=&formatter_charset= @54: Not allowed to load local resource: file:///C:/Program%20Files/Common%20Files/Microsoft%20Shared/Stationery/SoftBlue.jpg

** Message: console message: mail://1370695704.1835.5/desktop/Inbox/AAMkADM3MTQ2MTEyLTZjYzItNGY0ZS04ZGJmLTQ0Yzc3ZTUxZjg4ZQBGAAAAAADHbxaIUo7TRZMcZbnoBQvhBwAQmullzkq8SJBuVdAticoTAFtmvkMdAAATvkPzHvSERYVWWuBXIIzIAAAAB7z6AAA%3D?part_id=.message.related.0.alternative-prefer-plain.1.text_html&mode=2&formatter_default_charset=&formatter_charset= @55: Not allowed to load local resource: file:///C:/Program%20Files/Common%20Files/Microsoft%20Shared/Stationery/SoftBlue.jpg


(evolution:2252): GLib-GIO-CRITICAL **: g_file_info_get_content_type: assertion `G_IS_FILE_INFO (info)' failed

(evolution:2252): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x33aa340 is mapped but not visible

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x33aa340 is mapped but not visible

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x33aa340 is mapped but visible=0 child_visible=1 parent GtkBox 0x4324230 mapped=1

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x33aa340 is mapped but not visible

(evolution:2252): Gtk-WARNING **: EAttachmentBar 0x33aa340 is mapped but visible=0 child_visible=1 parent GtkBox 0x4324230 mapped=1

(evolution:2252): evolution-mail-WARNING **: Failed to request http://h9.img.mediacache.rugion.ru/_i/realty/photos/small/42/69/45/4269454_1370960550.jpg (code 404)

(evolution:2252): evolution-mail-WARNING **: Failed to request http://tracker.nmp1.com/WBS (code 500)

(evolution:2252): evolution-mail-WARNING **: Failed to request http://tracker.nmp1.com/WBS (code 500)

(evolution:2252): evolution-mail-WARNING **: Failed to request http://tracker.nmp1.com/WBS (code 500)

(evolution:2252): GLib-ERROR **: creating thread '': Error creating thread: Resource temporarily unavailable
Trace/breakpoint trap (core dumped)
Comment 19 Milan Crha 2013-08-19 04:19:37 EDT
*** Bug 998146 has been marked as a duplicate of this bug. ***
Comment 20 Milan Crha 2013-09-25 03:45:53 EDT
*** Bug 1011655 has been marked as a duplicate of this bug. ***
Comment 21 Milan Crha 2014-01-09 10:08:05 EST
According to [1], it seems you've got our of memory, and looking into pid status, comment #9, if I reed it correctly, the process uses 3.5GB of memory, which is too much for sure. Maybe there's leaking something during the time of using it. Am I right you can use evolution from the beginning, but it crashes this way (in g_thread_new() or similar), after some time of using it? I see from the bugzilla that you get this crash very often.

[1] http://stackoverflow.com/questions/9905257/git-push-fatal-unable-to-create-thread-resource-temporarily-unavailable
Comment 22 Milan Crha 2014-01-09 10:09:29 EST
*** Bug 1040629 has been marked as a duplicate of this bug. ***
Comment 23 Milan Crha 2014-01-09 10:18:05 EST
*** Bug 1040176 has been marked as a duplicate of this bug. ***
Comment 24 Milan Crha 2014-01-09 10:18:08 EST
*** Bug 1040247 has been marked as a duplicate of this bug. ***
Comment 25 Milan Crha 2014-01-09 10:18:37 EST
*** Bug 1040633 has been marked as a duplicate of this bug. ***
Comment 26 Milan Crha 2014-01-09 10:18:51 EST
*** Bug 1040551 has been marked as a duplicate of this bug. ***
Comment 27 Milan Crha 2014-01-09 10:18:52 EST
*** Bug 1040238 has been marked as a duplicate of this bug. ***
Comment 28 Milan Crha 2014-01-09 10:19:12 EST
*** Bug 1041568 has been marked as a duplicate of this bug. ***
Comment 29 Milan Crha 2014-01-15 09:42:28 EST
*** Bug 1050984 has been marked as a duplicate of this bug. ***
Comment 30 Milan Crha 2014-01-15 10:10:34 EST
*** Bug 1051770 has been marked as a duplicate of this bug. ***
Comment 31 shakka.by 2014-06-01 08:49:34 EDT
Another user experienced a similar problem:

I dont know what caused this incident and i don't use evolution anymore since 3 years. 

reporter:       libreport-2.2.2
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-calendar-factory
crash_function: g_thread_new
executable:     /usr/libexec/evolution-calendar-factory
kernel:         3.14.4-200.fc20.x86_64
package:        evolution-data-server-3.10.4-3.fc20
reason:         evolution-calendar-factory killed by SIGTRAP
runlevel:       N 5
type:           CCpp
uid:            1000
Comment 32 Milan Crha 2014-06-02 06:09:29 EDT
*** Bug 1046707 has been marked as a duplicate of this bug. ***
Comment 33 Milan Crha 2014-06-12 04:22:21 EDT
I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=731554
Comment 34 paris 2014-07-06 23:02:56 EDT
Upstream said no, so we'll still be getting this bug in Fedora 20 for a long time. Please re-open because upstream says they're not handling it.
Comment 35 Milan Crha 2014-07-07 09:22:29 EDT
They also said why and what to do (to increase resources on a kernel level). There is nothing you can do about it from an application point of view.
Comment 36 Mikhail 2014-07-08 12:44:55 EDT
We can reopen this bugreport?
If they offer to increase limits in the kernel then why we need any limits?
Comment 37 Milan Crha 2014-07-09 04:39:42 EDT
It's not a call for me, I am not able to answer your questions, it's all their decision, not mine. Please ask them instead. I'm not willing to reopen this bug report, because I cannot help in any way from the application point of view (maybe except of not using GLib, but that's not doable at all).
Comment 38 Mikhail 2014-07-10 03:49:42 EDT
We may ask GTK maintainer in Fedora to ask about it here?
Comment 39 Matthias Clasen 2014-07-10 13:24:44 EDT
And what do you want to ask ? What do you expect we should do if the kernel fails to create threads ?
Comment 40 Mikhail 2014-07-14 16:47:18 EDT
(In reply to Matthias Clasen from comment #39)
> And what do you want to ask ? What do you expect we should do if the kernel
> fails to create threads ?

If I understand correctly Milan requested that you not do crash in g_thread_new () if the kernel fails to create threads. Then he can handle the exception and write that processes limit is exceeded please repeat operation later.

Thanks.
Comment 41 Milan Crha 2014-07-15 01:35:19 EDT
(In reply to Mikhail from comment #40)
> If I understand correctly Milan requested that you not do crash in
> g_thread_new () if the kernel fails to create threads. Then he can handle
> the exception and write that processes limit is exceeded please repeat
> operation later.

That's not completely it. The GLib provides g_thread_try_new() which serves just for these purposes, but it's not always usable, because it's hard to decide what should happen when the new-thread-operation fails in this way. It's fine in a case of the first thread of a newly started operation, but if the thread is created in the middle of another asynchronous operation, then the state of the object the operation may modify is left in an inconsistent state (imagine it as some multi-step operation, when you fail to create a thread in the middle).

What I was objecting to was that the GLib resource requirements increased since 3.10.x, without proper communication to the systems/distributions (if GLib folks insist on too small kernel limits), which potentially makes any GLib-based application crash without actual issue in the application itself. The fact that GLib applications run persistent threads in each process, multiple of them - depending on the parts being used - and that there are usually running multiple such applications, makes the thread starve situation caused by GLib applications themselfs (at least partly).

This is only my personal opinion on the subject.
Comment 42 Matthias Clasen 2014-07-16 14:27:34 EDT
GLib creates 2 or 3 (if you are using gdbus) threads. At the same time, web browsers create hundreds.
Comment 43 Zbigniew Jędrzejewski-Szmek 2014-11-20 10:34:24 EST
Just FYI, I hit the same traceback after hitting the user limit on number of processes (ulimit -u), which is 1024 by default. I had firefox with ~700 threads. Raising it to 4096 fixes the issue for me.

Note You need to log in before you can comment on or make changes to this bug.