Bug 1046809 - Strange UI bug: tab "VM" unusable / oVirt 3.3.1+
Summary: Strange UI bug: tab "VM" unusable / oVirt 3.3.1+
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.3
Hardware: All
OS: Linux
low
high
Target Milestone: ---
: 3.5.0
Assignee: Frantisek Kobzik
QA Contact: Pavel Novotny
URL:
Whiteboard: virt
Depends On: 1062344
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-26 23:36 UTC by Yamakasi
Modified: 2016-02-10 19:47 UTC (History)
13 users (show)

Fixed In Version: ovirt-3.5.0-alpha1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-17 12:31:56 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 23809 0 None None None Never
oVirt gerrit 32973 0 master MERGED frontend: Fix NPE in os info Never
oVirt gerrit 32981 0 ovirt-engine-3.5 MERGED frontend: Fix NPE in os info Never

Description Yamakasi 2013-12-26 23:36:34 UTC
Description of problem:

In the Webgui of a 3.3.2 (and also 3.3.1) install there is a problem with javascript it seems.

As described in the topic below I also get greyed out icons on VM's, after a couple of refreshed sometimes some buttons are available for usage.

This also happens on the hosts tab it's host specific tabs. Networks is sometimes empty for a host, you need to click around in the tabs, the select tab hangs, some other is selected then where you actually on.

http://comments.gmane.org/gmane.comp.emulators.ovirt.user/12849

Version-Release number of selected component (if applicable):

3.3.2


How reproducible:

Go to the webadmin and click around


Steps to Reproduce:
1. Go to the webadmin
2. Click on VM's
3. Look at the VM buttons

Actual results:

Buttons are greyed out


Expected results:

Buttons should be avaiable


Additional info:

What I also have seen is that when I click on the console of a VM, the .vv file contains a different host than where it's running on.

Comment 1 Einav Cohen 2014-01-02 15:29:21 UTC
discussion/more details are in http://lists.ovirt.org/pipermail/users/2013-December/thread.html [look for "Strange UI bug"]

Comment 2 Einav Cohen 2014-01-02 16:01:14 UTC
(In reply to Yamakasi from comment #0)
> This also happens on the hosts tab it's host specific tabs. Networks is
> sometimes empty for a host, you need to click around in the tabs, the select
> tab hangs, some other is selected then where you actually on.

I am not sure if the above issue is related to the main VMs issue that was reported here and was also reported and already discussed in [1]. 
Moreover, in [2] it is mentioned that all other tabs are working as expected.

Please note that once there is an exception on the client side, there is no way of knowing how the GUI will behave from that point on. So I suggest to fix the known VM/OsRepository issue first, and then open a separate bug on additional issues, if there are any. Thanks. 

[1] http://lists.ovirt.org/pipermail/users/2013-December/thread.html [look for "Strange UI bug"]
[2] http://lists.ovirt.org/pipermail/users/2013-December/018491.html

Comment 3 Itamar Heim 2014-01-12 08:43:13 UTC
setting target release to current version for consideration and review. please do not push non-RFE bugs to an undefined target release to make sure bugs are reviewed for relevancy, fix, closure, etc.

Comment 4 Michal Skrivanek 2014-01-28 08:45:23 UTC
decreasing prio as this happens only when someone modifies osinfo

Comment 6 Michal Skrivanek 2014-02-03 10:49:46 UTC
lowering prio as this happens only after manual removal of OS type from config

Comment 7 Leonardo Bianconi 2014-02-06 17:17:51 UTC
There is a problem with the patch that fixed this bug. I just opened a new bug to fix that [1062344] for 3.5 target.

Comment 8 Pavel Novotny 2014-08-12 15:32:46 UTC
FailedQA in ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch (rc1).

The Gerrit patch http://gerrit.ovirt.org/23809 was practically reverted in bug 1062344, because it introduces a regression regarding default VM OS selection for x64/ppc archs.

IMHO probably the best solution will be to upload the patch #23809 again, extended by handling the OS architectures, which will also resolve bug 1062344.

Comment 9 Frantisek Kobzik 2014-09-16 12:07:37 UTC
It seems bugfix of 1062344 reverted part of the original solution. Posted small patch that should fix that.

Comment 10 Sandro Bonazzola 2014-10-17 12:31:56 UTC
oVirt 3.5 has been released and should include the fix for this issue.


Note You need to log in before you can comment on or make changes to this bug.