Bug 1047018 - [abrt] rhythmbox: INT_cairo_pattern_reference(): rhythmbox killed by SIGABRT
Summary: [abrt] rhythmbox: INT_cairo_pattern_reference(): rhythmbox killed by SIGABRT
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a34169a161e4cc1c15eabd2cc09...
: 1047154 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-28 11:46 UTC by Dario Castellarin
Modified: 2013-12-31 09:51 UTC (History)
21 users (show)

Fixed In Version: rhythmbox-3.0.1-3.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-31 09:51:11 UTC


Attachments (Terms of Use)
File: backtrace (119.15 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: cgroup (172 bytes, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: core_backtrace (99.39 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: dso_list (30.83 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: environ (1.49 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: limits (1.29 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: maps (155.66 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: open_fds (2.56 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: proc_pid_status (933 bytes, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details
File: var_log_messages (1.29 KB, text/plain)
2013-12-28 11:46 UTC, Dario Castellarin
no flags Details

Description Dario Castellarin 2013-12-28 11:46:23 UTC
Description of problem:
It crashes every time a few seconds after starting to play a song.

Version-Release number of selected component:
rhythmbox-3.0.1-2.fc20

Additional info:
reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        rhythmbox
crash_function: INT_cairo_pattern_reference
executable:     /usr/bin/rhythmbox
kernel:         3.12.6-300.fc20.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 INT_cairo_pattern_reference at cairo-pattern.c:1062
 #5 _cairo_gstate_set_source at cairo-gstate.c:401
 #6 INT_cairo_set_source at cairo.c:809
 #7 prepare_image at rb-fading-image.c:97
 #8 render_current at rb-fading-image.c:171
 #9 composite_into_current at rb-fading-image.c:666
 #10 rb_fading_image_set_pixbuf at rb-fading-image.c:696
 #11 art_cb at rb-header.c:461
 #12 ffi_call_unix64 at ../src/x86/unix64.S:76
 #13 ffi_call at ../src/x86/ffi64.c:522

Comment 1 Dario Castellarin 2013-12-28 11:46:30 UTC
Created attachment 842604 [details]
File: backtrace

Comment 2 Dario Castellarin 2013-12-28 11:46:32 UTC
Created attachment 842605 [details]
File: cgroup

Comment 3 Dario Castellarin 2013-12-28 11:46:35 UTC
Created attachment 842606 [details]
File: core_backtrace

Comment 4 Dario Castellarin 2013-12-28 11:46:37 UTC
Created attachment 842607 [details]
File: dso_list

Comment 5 Dario Castellarin 2013-12-28 11:46:39 UTC
Created attachment 842608 [details]
File: environ

Comment 6 Dario Castellarin 2013-12-28 11:46:41 UTC
Created attachment 842609 [details]
File: limits

Comment 7 Dario Castellarin 2013-12-28 11:46:43 UTC
Created attachment 842610 [details]
File: maps

Comment 8 Dario Castellarin 2013-12-28 11:46:45 UTC
Created attachment 842611 [details]
File: open_fds

Comment 9 Dario Castellarin 2013-12-28 11:46:47 UTC
Created attachment 842612 [details]
File: proc_pid_status

Comment 10 Dario Castellarin 2013-12-28 11:46:49 UTC
Created attachment 842613 [details]
File: var_log_messages

Comment 11 daramas444 2013-12-29 12:49:16 UTC
I can report the exact same problem when trying to listen to a web radio.

Comment 12 Robert Marcano 2013-12-29 14:41:39 UTC
This still happens after the update from bug 1043259 that has the same behaviour, crash immediately after a few milliseconds of sound

Comment 13 Eyal Kalderon 2013-12-29 16:51:11 UTC
I have experienced the same problem. Rhythmbox launches fine, but only manages to play the first 1-2 seconds of a song before abruptly crashing. Totem fails to start up at all; it runs perpetually in the background, albeit without crashing. Perhaps the root cause is a GStreamer issue?

Comment 14 George Beard 2013-12-29 17:22:46 UTC
I additionally can confirm this issue with Rhythmbox (playback of some media succeeds anyway, sometimes crashed appear instantly, other times some seconds of media are played, no difference wether MP3/OGG files are played back). Totem also fails to start up any GUI but still the tasks appear in the process list and consume some/a lot CPU time. Even though, I did not run any GStreamer updates but there was one for Rhythmbox during the last few days, if I am not at fault - (yum could not perform any downgrade though).

Comment 15 Oliver Pabst 2013-12-29 17:43:00 UTC
Another user experienced a similar problem:

After starting up rhythmbox the app crashes immediately after double-clicking a song to play.

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        rhythmbox
crash_function: INT_cairo_pattern_reference
executable:     /usr/bin/rhythmbox
kernel:         3.12.5-302.fc20.x86_64
package:        rhythmbox-3.0.1-2.fc20
reason:         rhythmbox killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 16 Robert Marcano 2013-12-29 17:47:35 UTC
(In reply to Eyal Kalderon from comment #13)
> I have experienced the same problem. Rhythmbox launches fine, but only
> manages to play the first 1-2 seconds of a song before abruptly crashing.
> Totem fails to start up at all; it runs perpetually in the background,
> albeit without crashing. Perhaps the root cause is a GStreamer issue?

I think this particular bug is not related to the Totem one you get, Totem works fine for me playing the same files, and it is able to play the same radio stations (the defaults that Rhythmbox provides) without problems and those make Rhythmbox crash too

Comment 17 Ronald Verbeek 2013-12-29 17:51:38 UTC
Today I have updated to rhythmbox.x86_64 0:3.0.1-2.fc20 and I experience the same problem. The previous release 3.0.1-1 was OK!

Comment 18 Onuralp SEZER 2013-12-30 00:12:18 UTC
Same problem I have it. I start the player and music and done crashed. I downgrade it and It's works I'm waiting for next update for proper work and get backup for this package otherwise It's gonna crash again.

Comment 19 Norman Gaywood 2013-12-30 01:18:49 UTC
Another user experienced a similar problem:

Upgraded rhythmbox
Entered a search term "you"
Had random selection and repeat on
pressed play and crash.

Happens everytime.

Did a yum downgrade and all works again:

Removed:
  rhythmbox.x86_64 0:3.0.1-2.fc20                                                                                     

Installed:
  rhythmbox.x86_64 0:3.0-3.fc20                                                                                       


reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        rhythmbox
crash_function: INT_cairo_pattern_reference
executable:     /usr/bin/rhythmbox
kernel:         3.12.5-302.fc20.x86_64
package:        rhythmbox-3.0.1-2.fc20
reason:         rhythmbox killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 20 mastaiza 2013-12-30 12:44:27 UTC
Another user experienced a similar problem:

proigrovaesh one track after the player crashes

reporter:       libreport-2.1.10
backtrace_rating: 4
cmdline:        rhythmbox
crash_function: INT_cairo_pattern_reference
executable:     /usr/bin/rhythmbox
kernel:         3.12.5-302.fc20.x86_64
package:        rhythmbox-3.0.1-2.fc20
reason:         rhythmbox killed by SIGABRT
runlevel:       N 5
type:           CCpp
uid:            1000

Comment 21 Gert Vervoort 2013-12-30 15:07:32 UTC
*** Bug 1047154 has been marked as a duplicate of this bug. ***

Comment 22 Gert Vervoort 2013-12-30 15:08:36 UTC
Description of problem:

When trying to play an mp3 file or internet radio, rhythmbox fails with:

rhythmbox: cairo-pattern.c:1062: cairo_pattern_reference: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.
Aborted


Version-Release number of selected component (if applicable):

rhythmbox.x86_64                      3.0.1-2.fc20                      @updates


How reproducible:

Always:
- Internet radio always
- mp3 playback sometimes works the first song, but then crashes when starting the next song

Steps to Reproduce:
1. in an X-terminal type: rhythmbox
2. click on an mp3 file or an internet radio channel for playback
3.

Actual results:

[gert@jupiter tmp]$ rhythmbox

(rhythmbox:2857): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid).  Unable to remove object from construction_objects list, so memory was probably just leaked.  Please use GInitable instead.

(rhythmbox:2857): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid).  Unable to remove object from construction_objects list, so memory was probably just leaked.  Please use GInitable instead.

(rhythmbox:2857): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid).  Unable to remove object from construction_objects list, so memory was probably just leaked.  Please use GInitable instead.
rhythmbox: cairo-pattern.c:1062: cairo_pattern_reference: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.
Aborted
[gert@jupiter tmp]$


Expected results:

Playback of the selected mp3 file or internet radio station without abort.

Comment 23 Mamoru TASAKA 2013-12-30 15:39:21 UTC
Perhaps
https://bugzilla.gnome.org/show_bug.cgi?id=719514
, which says the upstream git commit
https://git.gnome.org/browse/rhythmbox/commit/?id=344545b32a4fb7b1677be13bcb5c1f27eae7627f
caused this issue, so actually the fix for bug 1043259 caused this issue.

And the fix for this is
https://git.gnome.org/browse/rhythmbox/commit/?id=b151337685eff709060e805767a9e8c067f2776d

Adam, would you take a look at this?

Comment 24 Adam Williamson 2013-12-30 17:24:51 UTC
Well, foo. Thanks for the catch, Mamoru. Will backport asap.

Comment 25 Fedora Update System 2013-12-30 17:56:37 UTC
rhythmbox-3.0.1-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/rhythmbox-3.0.1-3.fc20

Comment 26 Onuralp SEZER 2013-12-30 17:59:02 UTC
Fixed thanks Adam !! I'm adding plus karma for it

Comment 27 Adam Williamson 2013-12-30 18:08:52 UTC
It might be best to give it an hour or two first - hasty positive karma is what caused the bad update to go out in the first place :)

Comment 28 Onuralp SEZER 2013-12-30 18:11:17 UTC
Adam; That was really fast fix karma for this bug but I think music listener lover already happy with patch ! :)

Comment 29 James Wrigley 2013-12-30 19:40:43 UTC
The update seems to do the opposite of what it should :P On my machine Rhythmbox crashes consistently with this same error when it tries to play a song with album art. This never happened before I updated this morning.

Comment 30 James Wrigley 2013-12-30 19:45:18 UTC
Whoops, my bad. This mornings update was for 3.0.1-2, looks like the mirrors haven't all synced yet.

Comment 31 Adam Williamson 2013-12-30 20:07:12 UTC
Yeah. 3.0.1-2 fixed https://bugzilla.redhat.com/show_bug.cgi?id=1043259 but caused this. 3.0.1-3 adds the upstream fix for this.

Comment 32 Adam Williamson 2013-12-30 20:07:57 UTC
3.0.1-3 has not even gone to mirrors yet. I only submitted it as an update two hours ago, it still needs to be picked up in a u-t compose and then mirrored, though you can grab it direct from koji to test.

Comment 33 Michael Catanzaro 2013-12-31 02:49:30 UTC
Thanks for the quick fix. These things happen when backporting... will be curious to see when Rhythmbox decides to grow a stable branch....

Comment 34 Benjamin Hahne 2013-12-31 06:54:46 UTC
Installing from Koji appears to have fixed this (GUI is reponsive again, for example).

I note that when I first encountered this problem, it crashed until I visited the preferences and plugins pages, then sporadically crashed after play start or crossfading between tracks (sometimes first track, sometimes after an hour).  FWIW.

Comment 35 Fedora Update System 2013-12-31 09:51:11 UTC
rhythmbox-3.0.1-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.