Bug 1047154 - rhythmbox: cairo-pattern.c:1062: cairo_pattern_reference: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.
Summary: rhythmbox: cairo-pattern.c:1062: cairo_pattern_reference: Assertion `((*&(&pa...
Keywords:
Status: CLOSED DUPLICATE of bug 1047018
Alias: None
Product: Fedora
Classification: Fedora
Component: rhythmbox
Version: 20
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-12-29 14:20 UTC by Gert Vervoort
Modified: 2013-12-30 15:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-12-30 15:07:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Gert Vervoort 2013-12-29 14:20:57 UTC
Description of problem:

When trying to play an mp3 file or internet radio, rhythmbox fails with:

rhythmbox: cairo-pattern.c:1062: cairo_pattern_reference: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.
Aborted


Version-Release number of selected component (if applicable):

rhythmbox.x86_64                      3.0.1-2.fc20                      @updates


How reproducible:

Always:
- Internet radio always
- mp3 playback sometimes works the first song, but then crashes when starting the next song

Steps to Reproduce:
1. in an X-terminal type: rhythmbox
2. click on an mp3 file or an internet radio channel for playback
3.

Actual results:

[gert@jupiter tmp]$ rhythmbox

(rhythmbox:2857): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid).  Unable to remove object from construction_objects list, so memory was probably just leaked.  Please use GInitable instead.

(rhythmbox:2857): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid).  Unable to remove object from construction_objects list, so memory was probably just leaked.  Please use GInitable instead.

(rhythmbox:2857): GLib-GObject-CRITICAL **: Custom constructor for class SoupServer returned NULL (which is invalid).  Unable to remove object from construction_objects list, so memory was probably just leaked.  Please use GInitable instead.
rhythmbox: cairo-pattern.c:1062: cairo_pattern_reference: Assertion `((*&(&pattern->ref_count)->ref_count) > 0)' failed.
Aborted
[gert@jupiter tmp]$


Expected results:

Playback of the selected mp3 file or internet radio station without abort.

Additional info:

Comment 1 Shivaram Lingamneni 2013-12-29 22:05:51 UTC
I'm on Fedora 20 and I'm affected by this bug. It seems to be a regression between 3.0-3.fc20 and 3.0.1-2.fc20, introduced as a byproduct of the fix for #1043259.

#1047018 may be a duplicate of this bug.

Comment 2 Gert Vervoort 2013-12-30 15:03:13 UTC
For me also the problem was introduced after upgrading to 3.0.1-2.fc20.

Looking at the backtrace in bug #1047018 also crashes at cairo-pattern.c:1062, it looks indeed that this is the same bug.

Comment 3 Gert Vervoort 2013-12-30 15:07:32 UTC

*** This bug has been marked as a duplicate of bug 1047018 ***


Note You need to log in before you can comment on or make changes to this bug.