Bug 10475 - Rebuilding kernel from source RPM produces faulty emu10k1 module
Summary: Rebuilding kernel from source RPM produces faulty emu10k1 module
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 6.2
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
: 11353 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-03-31 10:02 UTC by Antti Andreimann
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-11 00:36:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fixed EMU10k1 patch. There's only 1 modification SUB_DIRS -> MOD_SUB_DIRS (434.20 KB, patch)
2000-03-31 10:05 UTC, Antti Andreimann
no flags Details | Diff

Description Antti Andreimann 2000-03-31 10:02:53 UTC
When you rebuild kernel from source RPM emu10k1 module will have
unresolvable symbols. The problem is in drivers/sound/Makefile that
incorrectly adds emu10k1 directory to SUB_DIRS instead of MOD_SUB_DIRS
during compile. Make enters emu10k1 directory and compiles audio.c with
kernel symbols instead of module symbols. Later on, when modules are being
built this object file is considered as current and therfor will not be
recompiled.
I wonder how you guys at RedHat could build kernel RPM's with working
module? Did you remove audio.o during the build or replaced the module in
RPM's by hand? Bad bad boys! ;-)
I shall upload a modified emu10k1 patch to this bug report that fixes the
problem. However I know that Makefile is still not entirely correct. I see
now way emu10k1 can be compiled into kernel like this (this problem was NOT
caused by my modification). Unfortunatly I did not have time to fix and
test it. I can post a fix, but I need some1 with SBLive! to compile the
driver into kernel and test if it works. Also it would be nice if you could
inform creative guys about this problem. Im too lazy to do it myself ;-)

Comment 1 Antti Andreimann 2000-03-31 10:05:59 UTC
Created attachment 177 [details]
Fixed EMU10k1 patch. There's only 1 modification SUB_DIRS -> MOD_SUB_DIRS

Comment 2 David Mills 2000-05-11 00:36:59 UTC
*** Bug 11353 has been marked as a duplicate of this bug. ***

Comment 3 Michael K. Johnson 2000-08-04 20:55:48 UTC
We did not mangle the RPM; for reasons I have not investigated,
the problem simply didn't show up in our build system.

In any case, this is fixed in our current kernel source package.


Note You need to log in before you can comment on or make changes to this bug.