Bug 11353 - After compiling the kernel and modules emu10k1 won't load
After compiling the kernel and modules emu10k1 won't load
Status: CLOSED DUPLICATE of bug 10475
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-05-10 20:22 EDT by David Mills
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-05-10 20:36:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mills 2000-05-10 20:22:17 EDT
The emu10k1 driver delivered with the kernel loads correctly.  But after
recompiling the kernel and modules this driver no longer loads.  It
complains of missing symbols such as kfree.

I investigated and found that the file audio.o had been compiled during the
compilation of the kernel and thus was not compiled with -DMODULE.  After
recompiling this file with -DMODULE, re-linking emu10k1.o and placing it in
/lib/modules the sound driver then loads correctly.

I guess a makefile involved in the building of modules needs correcting.
Comment 1 David Mills 2000-05-10 20:36:59 EDT
*** This bug has been marked as a duplicate of 10475 ***

Note You need to log in before you can comment on or make changes to this bug.