Bug 104783 - TB GUI_functions.py:523:gui_run_dialog:OSError: [Errno 1] Operation not permitted
TB GUI_functions.py:523:gui_run_dialog:OSError: [Errno 1] Operation not permi...
Status: CLOSED DUPLICATE of bug 103421
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i686 Linux
low Severity low
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-21 18:08 EDT by David Langreth
Modified: 2006-02-21 13:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Langreth 2003-09-21 18:08:54 EDT
Description of problem:

Unhandled exception when activating network device control if
no modem is found

Version-Release number of selected component (if applicable):

component is a python script with no easily identifiable release number
on it

How reproducible:

100%

Steps to Reproduce:
1. configure ppp conection through modem
2. remove the modem (from pc card slot, in my case)
3. try to bring up the connection with redhat-control-network
    
Actual results:

Get message with dump, reporting unhandled exception, and suggesting
the dump be sent to bugzilla.

Expected results:

A reasonable error message telling the user what might be wrong.

Additional info:

Dump available on request (2053 bytes)
Comment 1 Harald Hoyer 2003-09-22 09:13:25 EDT
please attach the traceback
Comment 2 David Langreth 2003-10-27 18:05:38 EST
Component: redhat-config-network
Version: 1.2.15
Summary: TB79414994 GUI_functions.py:523:gui_run_dialog:OSError: [Errno 1]
Operation not permitted
Traceback (most recent call last):
  File "/usr/bin/redhat-control-network", line 199, in on_deactivateButton_clicked
    (ret, msg) = dev.deactivate()
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NCDevice.py",
line 396, in deactivate
    dialog = dialog)
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/NC_functions.py",
line 420, in generic_run_dialog
    dialog = dialog)
  File
"/usr/src/build/290630-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/GUI_functions.py",
line 523, in gui_run_dialog
OSError: [Errno 1] Operation not permitted

Local variables in innermost frame:
fdin: []
swindow: <gtk.ScrolledWindow object (GtkScrolledWindow) at 0x868941c>
string: <module 'string' from '/usr/lib/python2.2/string.pyc'>
okbutton: <gtk.Button object (GtkButton) at 0x8689554>
buffer: <gtk.TextBuffer object (GtkTextBuffer) at 0x8675c6c>
cancelbutton: <gtk.Button object (GtkButton) at 0x868950c>
command: /usr/sbin/usernetctl
argv: ['/usr/sbin/usernetctl', 'ppp1', 'down']
searchPath: 0
label: Deactivating network device GalaxyMV, please wait...
lbl: <gtk.Label object (GtkLabel) at 0x868930c>
select: <module 'select' from '/usr/lib/python2.2/lib-dynload/selectmodule.so'>
stdin: 0
xml: <gtk.glade.XML object (GladeXML) at 0x867eaac>
catchfd: (1, 2)
fderr: []
dlg: <gtk.Dialog object (GtkDialog) at 0x8688cac>
errlabel: Cannot deactivate network device GalaxyMV!

fdout: []
root: /
gtk: <module 'gtk' from '/usr/lib/python2.2/site-packages/gtk-2.0/gtk/__init__.pyc'>
CancelException: netconfpkg.gui.GUI_functions.CancelException
mark: <gtk.TextMark object (GtkTextMark) at 0x867be84>
write: 4
read: 3
s: 1
childpid: 13531
closefd: -1
dialog: None
rc: 
title: redhat-config-network:

Network device deactivating...
os: <module 'os' from '/usr/lib/python2.2/os.pyc'>
textview: <gtk.TextView object (GtkTextView) at 0x86894dc>
Comment 3 Harald Hoyer 2003-10-28 05:26:08 EST

*** This bug has been marked as a duplicate of 103421 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:58:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.