Bug 104819 - grub segfaults when run from the command line
grub segfaults when run from the command line
Status: CLOSED DUPLICATE of bug 90306
Product: Red Hat Linux Beta
Classification: Retired
Component: grub (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-22 12:03 EDT by Tom Diehl
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Diehl 2003-09-22 12:03:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
When I run grub from the command line running the setup command causes it to
segfault

Version-Release number of selected component (if applicable):
grub-0.93-6

How reproducible:
Always

Steps to Reproduce:
  GRUB  version 0.93  (640K lower / 3072K upper memory)

 [ Minimal BASH-like line editing is supported.  For the first word, TAB
   lists possible command completions.  Anywhere else TAB lists the possible
   completions of a device/filename.]

grub> root (hd0,0)
 Filesystem type is ext2fs, partition type 0x83

grub> setup (hd0)Segmentation fault
(tigger pts2) #
    

Actual Results:  seg fault

Expected Results:  the command should run

Additional info: Grub on RHL 8.0 works just fine. This is a dual boot machine.
8.0 and severn
Comment 1 Jeremy Katz 2003-09-22 12:56:01 EDT

*** This bug has been marked as a duplicate of 90306 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:39 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.