Bug 90306 - grub segfaults
grub segfaults
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: grub (Show other bugs)
prebeta
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Glen Foster
:
: 91875 99442 104819 (view as bug list)
Depends On:
Blocks: 90241 CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-05-06 13:01 EDT by Mike McLean
Modified: 2007-04-18 12:53 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 19:53:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of grub (11.58 KB, text/plain)
2003-05-06 13:05 EDT, Mike McLean
no flags Details

  None (edit)
Description Mike McLean 2003-05-06 13:01:17 EDT
* -re0505.2

getting a segfault from grub when I run grub-install. Will attach an strace.

This is causing some install cases to fail, primarily those installs where grub
was not already installed.
Comment 1 Mike McLean 2003-05-06 13:05:07 EDT
Created attachment 91518 [details]
strace of grub
Comment 2 Jeremy Katz 2003-05-06 15:56:19 EDT
New kernel will (hopefully) fix this...
Comment 3 Jeremy Katz 2003-05-07 23:07:08 EDT
Due to exec shield breaking nested function trampoline stuff.

Blah.  Worked around for now in the installer at least.  Hopefully we'll have
the newer version of the exec shield patch for the next beta and then I can use
chkstk to fix grub instead of turning off exec shield in the installer.
Comment 4 Mike McLean 2003-05-29 11:18:26 EDT
*** Bug 91875 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2003-09-22 12:55:15 EDT
*** Bug 99442 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2003-09-22 12:56:07 EDT
*** Bug 104819 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2003-09-24 19:53:11 EDT
exec shield stuff works now.

Note You need to log in before you can comment on or make changes to this bug.