Bug 90306 - grub segfaults
Summary: grub segfaults
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: grub (Show other bugs)
(Show other bugs)
Version: prebeta
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Glen Foster
URL:
Whiteboard:
Keywords:
: 91875 99442 104819 (view as bug list)
Depends On:
Blocks: 90241 CambridgeBlocker
TreeView+ depends on / blocked
 
Reported: 2003-05-06 17:01 UTC by Mike McLean
Modified: 2007-04-18 16:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-24 23:53:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace of grub (11.58 KB, text/plain)
2003-05-06 17:05 UTC, Mike McLean
no flags Details

Description Mike McLean 2003-05-06 17:01:17 UTC
* -re0505.2

getting a segfault from grub when I run grub-install. Will attach an strace.

This is causing some install cases to fail, primarily those installs where grub
was not already installed.

Comment 1 Mike McLean 2003-05-06 17:05:07 UTC
Created attachment 91518 [details]
strace of grub

Comment 2 Jeremy Katz 2003-05-06 19:56:19 UTC
New kernel will (hopefully) fix this...

Comment 3 Jeremy Katz 2003-05-08 03:07:08 UTC
Due to exec shield breaking nested function trampoline stuff.

Blah.  Worked around for now in the installer at least.  Hopefully we'll have
the newer version of the exec shield patch for the next beta and then I can use
chkstk to fix grub instead of turning off exec shield in the installer.

Comment 4 Mike McLean 2003-05-29 15:18:26 UTC
*** Bug 91875 has been marked as a duplicate of this bug. ***

Comment 5 Jeremy Katz 2003-09-22 16:55:15 UTC
*** Bug 99442 has been marked as a duplicate of this bug. ***

Comment 6 Jeremy Katz 2003-09-22 16:56:07 UTC
*** Bug 104819 has been marked as a duplicate of this bug. ***

Comment 7 Jeremy Katz 2003-09-24 23:53:11 UTC
exec shield stuff works now.


Note You need to log in before you can comment on or make changes to this bug.