Bug 1048383 - F20 upower shows extremely high value for energy-full causing battery indicator to show low battery icon inappropriately, time to charge value inaccurate and system sometimes hibernates
Summary: F20 upower shows extremely high value for energy-full causing battery indicat...
Keywords:
Status: CLOSED DUPLICATE of bug 1060579
Alias: None
Product: Fedora
Classification: Fedora
Component: upower
Version: 20
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-01-03 21:08 UTC by Matt Keith
Modified: 2014-02-02 20:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1060579 (view as bug list)
Environment:
Last Closed: 2014-02-02 20:43:50 UTC
Type: Bug


Attachments (Terms of Use)
Screenshot on battery showing inaccurate icon and power-settings panel with accurate battery level (832.19 KB, image/png)
2014-01-03 21:08 UTC, Matt Keith
no flags Details
upower --dump output running on battery. (1.42 KB, text/plain)
2014-01-03 21:11 UTC, Matt Keith
no flags Details
Screenshot while charging showing inaccurate time-to-charge value (832.19 KB, image/png)
2014-01-03 21:16 UTC, Matt Keith
no flags Details
upower --dump output while charging showing inaccurate time-to-full and energy-full value (1.37 KB, text/plain)
2014-01-03 21:17 UTC, Matt Keith
no flags Details
upower --monitor-detail output capturing problem starting (2.88 KB, text/plain)
2014-01-05 05:15 UTC, Matt Keith
no flags Details

Description Matt Keith 2014-01-03 21:08:41 UTC
Created attachment 845082 [details]
Screenshot on battery showing inaccurate icon and power-settings panel with accurate battery level

Description of problem:
In Fedora 20 the battery indicator shows a low battery icon while using the battery with a 90% or lower charge level (Similar to bug 995608 for F19).  Also time-to-charge values are very inaccurate once connected to power and charging (Similar to bug 1033969 for F19)

Version-Release number of selected component (if applicable):
upower-0.9.23-2.fc20.x86_64

How reproducible:
Issues occur any time the battery gets down to 90% or lower, or when charging battery back up.

Steps to Reproduce:
1. Disconnect AC from battery power
2. Use computer to get battery level down to at least 90%
3. Observe battery indicator icon is showing low battery warning while the power options panel and upower --dump display correct battery level
4. Connect power and observe time to charge indicator is quite inaccurate (perhaps based on inaccurate "energy-full" value reported by upower.)

Actual results:
-Battery indicator icon shows a critical low battery warning while on battery with 90% or less charge
-Time to charge indicator in power-level is inaccurate while charging back up

Expected results:
-The battery indicator icon should not display a critically low battery warning until the battery is appropriately low.
-When charging the time-to-charge indicator i the power options panel shows an inaccurate value.

Additional info:
-upower --dump displays correct value for battery percentage.
-upower --dump shows energy-full-level to be nearly 10x times higher than energy-full-design which may be contributing (similar to bug 1033969)
-my hardware is a macbookpro10,2 (early 2013 13" retina macbook pro)

Comment 1 Matt Keith 2014-01-03 21:11:22 UTC
Created attachment 845084 [details]
upower --dump output running on battery.

Comment 2 Matt Keith 2014-01-03 21:16:35 UTC
Created attachment 845086 [details]
Screenshot while charging showing inaccurate time-to-charge value

Comment 3 Matt Keith 2014-01-03 21:17:50 UTC
Created attachment 845087 [details]
upower --dump output while charging showing inaccurate time-to-full and energy-full value

Comment 4 Matt Keith 2014-01-04 03:39:03 UTC
A number of system updates were received this evening (including an update to kernel 3.12.6-300 from 3.12.5.302) which appear to have resolved my problem.  The battery icon is showing an appropriate level, upower --dump is showing the correct value for energy-full-level, and when charging the system reports the correct amount of time to charge.

Comment 5 Matt Keith 2014-01-04 07:32:17 UTC
Problem returns intermittently.  At one point after disconnecting the AC supply, my machine hibernated with 90% battery remaining.  It seems a reboot corrects the issue for some time when the energy-full-level value in upower --dump begins again showing an invalid amount.

Comment 6 Matt Keith 2014-01-05 05:14:16 UTC
Added additional attachment with 'upower --monitor-detail' output showing problem happening, initially both energy and energy-full display normal values, on the next check they both show exaggerated values, and on the final check energy returns to normal but energy-full stays at exaggerated value (until upower daemon is restarted.)

The version of upower installed is upower-0.9.23-2.fc20.x86_64

Comment 7 Matt Keith 2014-01-05 05:15:07 UTC
Created attachment 845676 [details]
upower --monitor-detail output capturing problem starting

Comment 8 Matt Keith 2014-01-14 08:00:21 UTC
I have experienced the system inappropriately hibernating twice in the past 2 days due to upower misreporting values.  Not only does it misreport energy_full at times, it also periodically reports energy: to be 0 (quite inaccurately).  

Until this can be resolved I created a perl script to monitor and restart upowerd anytime Energy: = 0 or Energy-Full > 1.1x Energy-Full-Design.

Comment 9 Matt Keith 2014-01-18 00:24:25 UTC
Here's the instances just today when my script had to restart upowerd...

Fri Jan 17 00:41:41 2014 restarted upowerd because
energy-full was 646.83 greater than acceptable 72.6
Fri Jan 17 03:11:12 2014 restarted upowerd because
energy-full was 641.86 greater than acceptable 72.6
Fri Jan 17 03:34:49 2014 restarted upowerd because
energy-full was 634.94 greater than acceptable 72.6
Fri Jan 17 03:34:56 2014 restarted upowerd because
energy-full was 643.41 greater than acceptable 72.6
Fri Jan 17 04:26:11 2014 restarted upowerd because
energy-full was 638.78 greater than acceptable 72.6
Fri Jan 17 07:34:09 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 07:43:51 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 07:45:30 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 07:47:08 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 08:42:48 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 08:44:27 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 09:25:37 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 10:09:15 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 10:10:53 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 10:12:31 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 10:38:43 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 11:03:24 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 11:16:02 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 11:54:45 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 12:22:28 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 12:30:04 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 12:52:46 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 13:31:01 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 15:01:39 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 15:08:47 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 15:13:56 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 16:26:23 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 17:16:34 2014 restarted upowerd because
energy-full was 324.694 greater than acceptable 72.6
Fri Jan 17 18:07:28 2014 restarted upowerd because
energy was reporting unacceptable value at 0
Fri Jan 17 19:05:09 2014 restarted upowerd because
energy-full was 642.84 greater than acceptable 72.6
[katmeef@katmeefs ~]$

Comment 10 Matt Keith 2014-01-22 05:25:10 UTC
Even with my script checking every 7 seconds, the system still occasionally goes into hibernation mode erroniously.  This is getting to the point I will need to stop using Fedora core as it's seriously interrupting my ability to work on this machine.  Is there any chance this will be addressed?

Comment 11 Matt Keith 2014-02-02 20:39:27 UTC
Almost a month after reporting this bug there has been no activity other than my own. Did I mess it up by closing the bug when I thought the problem was fixed then reopening when I realized it was not?  Maybe I should make another bug report?  Anyways my system just hibernated again inappropriately, here's the output from my script showing that upower was in fact showing 0% when there was plenty of battery power remaining...


Sun Feb 2 15:34:37 2014 restarting upowerd because
energy was reporting unacceptable value at 0
Device: /org/freedesktop/UPower/devices/line_power_ADP1
  native-path:          ADP1
  power supply:         yes
  updated:              Sun 02 Feb 2014 03:23:58 PM EST (639 seconds ago)
  has history:          no
  has statistics:       no
  line-power
    online:             no

Device: /org/freedesktop/UPower/devices/battery_BAT0
  native-path:          BAT0
  vendor:               DPONz45165UF957A7123456789ABCDE
  model:                bq20z45165UF957A7123456789ABCDE
  power supply:         yes
  updated:              Sun 02 Feb 2014 03:34:33 PM EST (4 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    energy:              0 Wh
    energy-empty:        0 Wh
    energy-full:         62.26 Wh
    energy-full-design:  66 Wh
    energy-rate:         0 W
    voltage:             10.88 V
    percentage:          0%
    capacity:            94.3333%
  History (charge):
    1391373273	0.000	discharging
    1391373243	37.000	discharging
    1391373213	36.000	discharging
  History (rate):
    1391373273	0.000	discharging
    1391373243	33.606	discharging
    1391373213	35.905	discharging
    1391373183	39.038	discharging

Daemon:
  daemon-version:  0.9.23
  on-battery:      yes
  on-low-battery:  yes
  lid-is-closed:   no
  lid-is-present:  yes
  is-docked:       no
/sys/class/power_supply/ADP1/type:Mains
/sys/class/power_supply/ADP1/power/control:auto
/sys/class/power_supply/ADP1/power/async:disabled
/sys/class/power_supply/ADP1/power/wakeup_abort_count:0
/sys/class/power_supply/ADP1/power/wakeup_active:0
/sys/class/power_supply/ADP1/power/wakeup_total_time_ms:0
/sys/class/power_supply/ADP1/power/wakeup_active_count:1
/sys/class/power_supply/ADP1/power/runtime_enabled:disabled
/sys/class/power_supply/ADP1/power/runtime_active_kids:0
/sys/class/power_supply/ADP1/power/runtime_active_time:0
/sys/class/power_supply/ADP1/power/wakeup_max_time_ms:0
/sys/class/power_supply/ADP1/power/wakeup_count:1
/sys/class/power_supply/ADP1/power/wakeup_last_time_ms:2323
/sys/class/power_supply/ADP1/power/wakeup:enabled
/sys/class/power_supply/ADP1/power/runtime_status:unsupported
/sys/class/power_supply/ADP1/power/runtime_usage:0
/sys/class/power_supply/ADP1/power/wakeup_expire_count:0
/sys/class/power_supply/ADP1/power/runtime_suspended_time:0
/sys/class/power_supply/ADP1/online:0
/sys/class/power_supply/ADP1/uevent:POWER_SUPPLY_NAME=ADP1
/sys/class/power_supply/ADP1/uevent:POWER_SUPPLY_ONLINE=0
/sys/class/power_supply/BAT0/type:Battery
/sys/class/power_supply/BAT0/power_now:33732000
/sys/class/power_supply/BAT0/alarm:0
/sys/class/power_supply/BAT0/power/control:auto
/sys/class/power_supply/BAT0/power/async:disabled
/sys/class/power_supply/BAT0/power/wakeup_abort_count:0
/sys/class/power_supply/BAT0/power/wakeup_active:0
/sys/class/power_supply/BAT0/power/wakeup_total_time_ms:0
/sys/class/power_supply/BAT0/power/wakeup_active_count:1
/sys/class/power_supply/BAT0/power/runtime_enabled:disabled
/sys/class/power_supply/BAT0/power/runtime_active_kids:0
/sys/class/power_supply/BAT0/power/runtime_active_time:0
/sys/class/power_supply/BAT0/power/wakeup_max_time_ms:0
/sys/class/power_supply/BAT0/power/wakeup_count:1
/sys/class/power_supply/BAT0/power/wakeup_last_time_ms:2859
/sys/class/power_supply/BAT0/power/wakeup:enabled
/sys/class/power_supply/BAT0/power/runtime_status:unsupported
/sys/class/power_supply/BAT0/power/runtime_usage:0
/sys/class/power_supply/BAT0/power/wakeup_expire_count:0
/sys/class/power_supply/BAT0/power/runtime_suspended_time:0
/sys/class/power_supply/BAT0/capacity:37
/sys/class/power_supply/BAT0/status:Discharging
/sys/class/power_supply/BAT0/voltage_now:10878000
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_NAME=BAT0
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_STATUS=Discharging
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_PRESENT=1
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_TECHNOLOGY=Unknown
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_CYCLE_COUNT=0
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_VOLTAGE_MIN_DESIGN=11210000
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_VOLTAGE_NOW=10878000
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_POWER_NOW=33732000
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_ENERGY_FULL_DESIGN=66000000
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_ENERGY_FULL=62260000
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_ENERGY_NOW=23270000
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_CAPACITY=37
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_MODEL_NAME=bq20z45165UF957A7123456789ABCDE
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_MANUFACTURER=DPONz45165UF957A7123456789ABCDE
/sys/class/power_supply/BAT0/uevent:POWER_SUPPLY_SERIAL_NUMBER=
/sys/class/power_supply/BAT0/energy_now:23270000
/sys/class/power_supply/BAT0/model_name:bq20z45165UF957A7123456789ABCDE
/sys/class/power_supply/BAT0/manufacturer:DPONz45165UF957A7123456789ABCDE
/sys/class/power_supply/BAT0/technology:Unknown
/sys/class/power_supply/BAT0/cycle_count:0
/sys/class/power_supply/BAT0/energy_full_design:66000000
/sys/class/power_supply/BAT0/voltage_min_design:11210000
/sys/class/power_supply/BAT0/energy_full:62260000
/sys/class/power_supply/BAT0/present:1
[root@katmeefs katmeef]#

Comment 12 Matt Keith 2014-02-02 20:43:50 UTC

*** This bug has been marked as a duplicate of bug 1060579 ***


Note You need to log in before you can comment on or make changes to this bug.