Bug 1048818 - Default monitor socket timeout is 3 seconds, which is way too short
Default monitor socket timeout is 3 seconds, which is way too short
Status: CLOSED DUPLICATE of bug 987088
Product: Virtualization Tools
Classification: Community
Component: libvirt (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
:
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2014-01-06 06:44 EST by Richard W.M. Jones
Modified: 2014-01-08 10:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-08 10:50:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard W.M. Jones 2014-01-06 06:44:41 EST
Description of problem:

Check out the number of hits for:
https://www.google.co.uk/search?q="monitor+socket+did+not+show+up"

In the code (src/qemu/qemu_monitor.c) it looks as if the
default timeout is 3 seconds.  I'm not clear if that is 3 seconds
after the fork, 3 seconds after some other qemu event, or what,
but given the number of people who hit this timeout it looks like
this is much too short.

libguestfs hits this bug under load (bug 892273).

Version-Release number of selected component (if applicable):

libvirt from git

How reproducible:

100%

Steps to Reproduce:

  $ cat > /tmp/qemu.wrapper
  #!/bin/sh                                                                     
  sleep 20
  exec qemu-kvm "$@"
  
  $ chmod +x /tmp/qemu.wrapper
  
  $ LIBGUESTFS_QEMU=/tmp/qemu.wrapper libguestfs-test-tool
  [...]
  Original error from libvirt: monitor socket did not show up: No such file or d
irectory [code=38 domain=10]
Comment 1 Cole Robinson 2014-01-08 10:50:16 EST

*** This bug has been marked as a duplicate of bug 987088 ***

Note You need to log in before you can comment on or make changes to this bug.