This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 987088 - Trying to create VM with host IO pressure: Unable to complete install: 'monitor socket did not show up: No such file or directory'
Trying to create VM with host IO pressure: Unable to complete install: 'monit...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
20
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
: 1048818 (view as bug list)
Depends On:
Blocks: TRACKER-bugs-affecting-libguestfs
  Show dependency treegraph
 
Reported: 2013-07-22 12:53 EDT by Dhiru Kholia
Modified: 2014-03-24 23:44 EDT (History)
20 users (show)

See Also:
Fixed In Version: libvirt-1.1.3.3-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-25 19:30:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (2.53 KB, patch)
2013-12-30 12:03 EST, Pavel Fux
pavel: review+
Details | Diff

  None (edit)
Description Dhiru Kholia 2013-07-22 12:53:18 EDT
Description of problem:

When trying to create a new RHEL / CentOS 5.8 guest VM on a Fedora 19 host, I get,

Unable to complete install: 'monitor socket did not show up: No such file or directory'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 100, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/create.py", line 1920, in do_install
    guest.start_install(False, meter=meter)
  File "/usr/share/virt-manager/virtinst/Guest.py", line 1134, in start_install
    noboot)
  File "/usr/share/virt-manager/virtinst/Guest.py", line 1202, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2782, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: monitor socket did not show up: No such file or directory

Version-Release number of selected component (if applicable):

$ uname -r
3.9.9-302.fc19.x86_64

$ rpm -qa | grep virt-manager
virt-manager-common-0.10.0-1.fc19.noarch
virt-manager-0.10.0-1.fc19.noarch

$ rpm -qa | grep kvm        
libvirt-daemon-kvm-1.0.5.2-1.fc19.x86_64
qemu-kvm-1.4.2-4.fc19.x86_64

How reproducible:

Put host system under IO pressure and try to create a new guest VM.

Expected results:

Things should just work :-)
Comment 1 Cole Robinson 2013-08-30 18:56:44 EDT
Moving to the upstream tracker.

The qemu driver has internal timeouts here waiting for the monitor socket to appear. I'm not really sure what the solution is though, we can't wait forever because qemu might hang before creating the monitor socket.
Comment 3 Pavel Fux 2013-12-30 12:01:44 EST
Hi,

I have come across this bug as well.
the default code behavior is wait for 3 seconds and if the socket is not opened yet, print this error and terminate.

the code is in file named src/qemu/qemu_monitor.c in function qemuMonitorOpenUnix.

In 2009 there was a patch that added the original 3 seconds retry, the patch can be found here:

http://www.redhat.com/archives/libvir-list/2009-July/msg00335.html

I have added a patch with this solution:

the default behavior stays the same, but a user can add a configuration variable to qemu.conf and change the timeout value.

every system needs a different value according to their system configuration but anyway 3 seconds is not suitable for all cases.

I am attaching my patch.

Pavel Fux.
Comment 4 Pavel Fux 2013-12-30 12:03:07 EST
Created attachment 843475 [details]
patch
Comment 5 Laine Stump 2014-01-02 05:40:22 EST
Pavel - would it be possible for you to post that patch (by using "git send-email") to libvir-list@redhat.com? That is the standard method for getting patches into libvirt; a patch buried in an upstream tracker bug report often goes unnoticed / beyond the attention span of libvirt developers for quite awhile, but we're all monitoring the mailing list constantly.
Comment 6 Laine Stump 2014-01-02 07:13:46 EST
Ah, never mind. Now that I've caught up on *all* my libvirt mail, I see that you've already sent it to the list :-)

https://www.redhat.com/archives/libvir-list/2013-December/msg01326.html
Comment 8 Cole Robinson 2014-01-08 10:50:17 EST
*** Bug 1048818 has been marked as a duplicate of this bug. ***
Comment 10 Cole Robinson 2014-01-08 10:51:29 EST
From the dup'd bug: 

Check out the number of hits for:
https://www.google.co.uk/search?q="monitor+socket+did+not+show+up"
Comment 11 Martin Kletzander 2014-01-17 02:47:06 EST
Hopefully fixed upstream by v1.2.1-11-gfe89b68:

commit fe89b687a02d1a8e1dce695a67b4f9d2c254d7b9
Author: Martin Kletzander <mkletzan@redhat.com>
Date:   Thu Jan 9 07:57:59 2014 +0100

    qemu: Change the default unix monitor timeout
Comment 12 Pavel Fux 2014-01-20 04:34:37 EST
(In reply to Martin Kletzander from comment #11)
> Hopefully fixed upstream by v1.2.1-11-gfe89b68:
> 
> commit fe89b687a02d1a8e1dce695a67b4f9d2c254d7b9
> Author: Martin Kletzander <mkletzan@redhat.com>
> Date:   Thu Jan 9 07:57:59 2014 +0100
> 
>     qemu: Change the default unix monitor timeout

at least in my case changing the value to 30 seconds is not enough, we had to change it to 5 minutes

I suggest you let the user change it as he wishes.
Comment 13 Martin Kletzander 2014-01-20 04:57:11 EST
(In reply to Pavel Fux from comment #12)
Thank you for pointing that out, but may I ask you to raise this issue on the upstream libvirt list?  Although I'm afraid that 5 minute timeout already borders with over-commiting the host machine.  If qemu takes so long to start, I'm thinking this might be handled in a different way.
Comment 14 Fedora Update System 2014-01-20 17:51:30 EST
libvirt-1.1.3.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/libvirt-1.1.3.3-2.fc20
Comment 15 Fedora Update System 2014-01-21 22:11:19 EST
Package libvirt-1.1.3.3-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvirt-1.1.3.3-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-1264/libvirt-1.1.3.3-2.fc20
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2014-01-25 19:30:17 EST
libvirt-1.1.3.3-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.