Bug 104888 - Installing perl-5.6.1-36.1.71 breaks mod_perl-1.24_01-2
Installing perl-5.6.1-36.1.71 breaks mod_perl-1.24_01-2
Status: CLOSED DUPLICATE of bug 104875
Product: Red Hat Linux
Classification: Retired
Component: mod_perl (Show other bugs)
i386 Linux
high Severity high
: ---
: ---
Assigned To: Gary Benson
David Lawrence
: 104943 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2003-09-23 05:24 EDT by Jon Warbrick
Modified: 2006-02-21 13:58 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:58:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jon Warbrick 2003-09-23 05:24:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
After installing perl-5.6.1-36.1.71 (and apache-1.3.27-2.7.1.i386.rpm,
mod_ssl-2.8.12-2.7.i386.rpm and related dependancies, but I don't think they are
involved), a mod_perl enabled apache refuses to start, reporting

  Can't locate strict.pm in @INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux
/usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux
/usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl . /etc/httpd/
/etc/httpd/lib/perl) at /usr/lib/perl5/site_perl/5.6.0/i386-linux/Apache.pm line 3.

I suspect that this is becasue the perl upgrade removed the old
/usr/lib/perl5/5.6.0 directory but that this is hard-coded into the search path
in the mod_perl binary.

Actually I's assume a new 5.6.1-based mod_perl is actually needed to match the
new stand-alone perl.

This problem may additionally apply to RH7.2 and RH7.3.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.install perl-5.6.1-36.1.71
2.attempt to restart a mod_perl-using apache


Actual Results:  Apache should restart

Expected Results:  Apache doesn't restart

Additional info:
Comment 1 Need Real Name 2003-09-23 08:02:09 EDT
Go get the SRPM for mod_perl and do:

rpm --rebuild mod_perl-1.24_01-2.src.rpm


rpm -Uvh --force mod_perl-1.24_01-2.i386.rpm

and you are good to go.
Comment 2 David Lawrence 2003-09-23 09:16:01 EDT

*** This bug has been marked as a duplicate of 104875 ***
Comment 3 Joe Orton 2004-01-03 13:52:38 EST
*** Bug 104943 has been marked as a duplicate of this bug. ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:58:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.