Bug 104943 - After updating to Apache 1.3.27-2.7.1 and Perl 5.6.1 on Sept 23, the httpd server would not start.
After updating to Apache 1.3.27-2.7.1 and Perl 5.6.1 on Sept 23, the httpd se...
Status: CLOSED DUPLICATE of bug 104888
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 15:21 EDT by Andrew McNeil
Modified: 2006-02-21 13:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew McNeil 2003-09-23 15:21:23 EDT
Description of problem:

After updating to Apache 1.3.27-2.7.1 and Perl 5.6.1 on Sept 23 using the
up2date utility, the httpd server will not restart.

Version-Release number of selected component (if applicable):

Apache 1.3.27-2.7.1 and Perl 5.6.1

How reproducible:

Always

Steps to Reproduce:
1. Update httpd and Perl
2. /sbin/service restart
3. Error message is produced to stdout
    
Actual results:

httpd exits with an error, does not start

Expected results:

httpd starts

Additional info:

Unexpected bummer. This is a production server which serves between 10k and 100k
http requests per week.
Comment 1 Andrew McNeil 2003-09-23 15:23:50 EDT
Error Report:

Sep 23 12:18:25 dan httpd: httpd shutdown succeeded
Sep 23 12:18:26 dan httpd: [Tue Sep 23 12:18:26 2003] [error] Can't locate
strict.pm in @INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux
/usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux
/usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl . /etc/httpd/
/etc/httpd/lib/perl) at /usr/lib/perl5/site_perl/5.6.0/i386-linux/Apache.pm line
3.!BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.6.0/i386-linux/Apache.pm line 3.!Compilation failed
in require at (eval 1) line 3.!
Comment 2 Jon Warbrick 2003-09-24 05:19:08 EDT
In case you hadn't noticed, this looks to be a DUPL of

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=104888

which contains a work-around that does work.
Comment 3 Joe Orton 2004-01-03 13:52:36 EST

*** This bug has been marked as a duplicate of 104888 ***
Comment 4 Red Hat Bugzilla 2006-02-21 13:58:41 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.