Bug 104922 - oops in md_thread
oops in md_thread
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 104958 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-09-23 12:08 EDT by Mike McLean
Modified: 2015-01-04 17:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-28 21:05:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McLean 2003-09-23 12:08:50 EDT
* Severn-0.93.2-i386
* raid5 on /usr

Got the following oops.  Console was locked so I could not tell when it
happened, but it was most likely during or very shortly after the boot process.
 The machine is a Proliant DL380 G2 with a smartarray (cciss).  Will try to
replicate.

 virtual address 0000001e
*pde = 00000000
Oops: 0000
e100 floppy microcode keybdev mousedev hid input usb-ohci usbcore ext3 jbd raid5
xor cciss sd_mod scsi_mod
CPU:    1
EIP:    0060:[<c0120624>]   Not tainted
EFLAGS: 00010046

EIP is at schedule [kernel] 0x484 (2.4.22-1.2061.nptlsmp)
eax: 00000002   ebx: c040b380   ecx: c040bc90   edx: c040b818
esi: 0000008c   edi: ffffffd6   ebp: f7277fa8   esp: f7277f60
ds: 0068   es: 0068   ss: 0068
Process raid5d (pid: 20, stackpage=f7277000)
Stack: 00000000 00000000 00000000 00000000 00000000 c040b81c f7276000 000057cd
       4bdbc0d3 00000018 c040bc90 c040b818 c040b380 00000000 00000001 f7276000
       f7276000 f7279fa4 f7279fac c021c545 f7287400 f8849e8b f72c5d10 f7276000
Call Trace:   [<c021c545>] md_thread [kernel] 0x1c5 (0xf7277fac)
[<f8849e8b>] .rodata.str1.1 [raid5] 0x56 (0xf7277fb4)
[<c021c380>] md_thread [kernel] 0x0 (0xf7277fe0)
[<c01075ad>] kernel_thread_helper [kernel] 0x5 (0xf7277ff0)


Code: 8b 47 48 85 c0 0f 8e 91 00 00 00 8b 5d d8 8b 75 dc 2b 5f 40
Comment 1 Dave Jones 2003-09-23 12:19:46 EDT
what kernel version was this ?
Comment 2 Mike McLean 2003-09-23 13:31:59 EDT
from the oops: 2.4.22-1.2061.nptlsmp
i.e. kernel-smp-2.4.22-1.2061.nptl.i686.rpm
Comment 3 Mike McLean 2003-09-24 15:51:59 EDT
just got a similar trace with raid1 (same machine, Cambridge-re0924.nightly)

CPU:    1
EIP:    0060:[<c01202bd>]   Not tainted
EFLAGS: 00010082

EIP is at schedule [kernel] 0x11d (2.4.22-1.2061.nptlsmp)
eax: 00000008   ebx: 00000000   ecx: f727c02c   edx: f727c000
esi: f727c000   edi: f727c000   ebp: f727ded8   esp: f727de90
ds: 0068   es: 0068   ss: 0068
Process raid1d (pid: 19, stackpage=f727d000)
Stack: c03f9800 00000000 c037f9b8 00000000 c010bcfb f727c068 f727c000 00036511
       99a29fbc 00000023 0000000b c0129437 c040b380 00000000 00000001 c037dc00
       c405e1ac f727c000 0000000b c01298dc f727c000 f7270068 f727dfc4 f727c000
Call Trace:   [<c010bcfb>] do_IRQ [kernel] 0xfb (0xf727dea0)
[<c0129437>] exit_notify [kernel] 0xf7 (exf727debc)
[<c01298dc>] do_exit [kernel] 0x30c (0xf727dedc)
[<c010a604>] die [kernel] 0x94 (0xf727def8)
[<c011e0a4>] do_page_fault [kernel] 0x2b4 (0xf727df0c)
[<c0120769>] schedule [kernel] 0x5c9 (0xf727df5c)
[<c011ddf0>] do_page_fault [kernel] 0x0 (0xf727dfb0)
[<c0109ff0>] error_code [kernel] 0x34 (0xf727dfb8)
[<c021002b>] fbcon_setup [kernel] 0x67b (0xf727dfe0)


Code: ff 0b 8b 51 04 8b 46 2c 89 50 04 89 02 c7 41 04 00 00 00 00
Comment 4 David Woodhouse 2003-09-25 09:57:12 EDT
I see similar oopsen, and also silent lockups, lockups with just 'Unable to
handle kernel NULL pointer dereference' and oopsen with kernel threads
apparently trying to access user space. 

kernel-smp-2.4.22-1.2061.nptl.athlon.rpm, again with RAID.
Comment 5 Dave Jones 2003-09-28 21:05:06 EDT
Should be fixed as of 2075, please reopen if it reappears.
Comment 6 Dave Jones 2003-09-28 21:06:23 EDT
*** Bug 104958 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.